MC 8790 with Linux 12.04 and 17.40


#1

We have developed a ppp application using the free source code which is currently at 17.40

We have been trying to move this to Ubuntu version 12.04 server but have been having some difficulties.

We have tried MC8780 cards and also MC8790V cards.

Our software and 17.40 all worked fine with both cards on Ubuntu 11.04

Since moving to 12.04 server we can use cu-l to connect to /dev/ttyUSB0 but any AT commands causes a hang.

When we try and run ifup ppp0 this seems to go around in a loop continually trying to connect but then disconnecting and trying again

We have a feeling that perhaps it has something to do with pppoe setup or configuration.

Can anyone confirm that they have this driver working with Ubuntu version 12.04 please?
Can anyone let us know if they needed to make any changes to anything in order for this to work?
Can anyone let us know how to debug ppp on Linux for the setup that is required for 17.40 driver?

Thanks,


#2

When upgrading from Ubuntu 11.04 to 12.04, the kernel was also changed from 2.6.38 to 3.2 (correct me if I am wrong).

Kindly use the driver for Kernel 3.x attached and try again.
v1.7.40_kernel-3.0.serial.tar (50 KB)

Hope this help.
Lo