Issues connecting in 2G using PAP

We are intending to use an HL7802 or HL7812 as a replacement for the HL7692.
We do not have IoT or CatM1 coverage in the area, so I am currently trying to get it to connect to 2G.
I have used the AT+KSETACQ command to set it to 2G and it appears to connect to the network (AT+CREG returns 5 or 1 depending on the SIM).
When I try to go online
AT+KCNXCFG=1,“GPRS”,“apn”,“user”,“password”
AT+KTCPCFG=1,0,“address”,port
AT+KTCPSTART=1
It returns 906 on the last step. All this works fine on the HL7692, HL6528 & HL8548.
One difference I have noticed is that the AT+WPPP command now has a CHAP option, whereas the other versions only had PAP. I have also noticed that it reverts to CHAP regardless of what I set it to when I use
AT+KTCPSTART=1.
Is there a way to force into PAP?
Is there another set of commands I should be using?

Hi sierra4,

Is your firmware up-to-date?

In 2G, before making a TCP or UDP connection, please make sure PDP context is activated.
AT+CGDCONT=1,“IP”,“your_APN”
AT+CGACT=1,1
AT+CGDCONT?

Thanks,

Hi,

The firmware is the latest available (4.6.9.4)
The APN requires a user & password, so I have been using
AT+WPPP=x,1,“user”,“password” to set these (x=0, 1 or 2)
AT+CGATT=1,1 helpfully replies with “ERROR” (no number) but AT+CEER returns
"+CEER: USER_AUTHENTICATION_FAILED ".
I have also tried
AT+KCNXCFG=1,“GPRS”,“apn”,“user”,“password”
both in combination with the above and without. This is the command I used with the previous HL (6528, 8548 & 7692) modules to set the apn.
The SIM provider’s web site indicates that the user name & password are not being sent.
(Password is blank when it works, possibly hidden)

Thanks,
Dave.

Hi sierra4,

The AT document mentions that if credentials and/or are modified while the radio is off (CFUN=0 or CFUN=4), the device must be reset to take them into account.

So try these steps before the KCNXCFG command:

  • Turn off the radio: AT+CFUN=4
  • Define PDP: AT+CGDCONT=1,“IP”,“your_APN”
  • Config Authentication for PDP: AT+WPPP=x,1,“user”,“password”
  • Restart the module: AT+CFUN=1,1

Thanks,