HL7692 2G Connectivity Issue

I am using the HL7692 modem and I connect it to a 2G (GSM) operator, communication can’t seem to be established correctly. A TLS session should be opened after the SIM replies, however this never happens. When using a 4G operator, communication can be achieved without any issues. I’m using AT commands on a mangOH Green board.

AT Commands used:
AT+COPS? (Verifying that I have successfully connected to a 2G network)

These responses are received after necessary commands are completed:
+STKPRO: 19,"",0,0
+STKCNF: 64,32,2,145
+STKCNF: 39,0,255,144

I also tested 2G connectivity with a WP7607 module which was successful using the same methods and environment as above.

Any help would be appreciated.

Hi PMcC,

Could you kindly provide the full AT log (2G network) with HL7692 and WP7607 to undertand the test case?

Hi Sierra_klin1,
Thanks for your reply. See below full AT commands used for each test (The AT commands had to vary slightly to cater for the different modules e.g. +wdss and +cgdcont for setting APN):

H7692 4G Test.txt (1.8 KB)
HL7692 2G Test Fail.txt (531 Bytes)
WP7607 2G Test.txt (855 Bytes)
WP7607 4G Test.txt (822 Bytes)

For HL7692, maybe you need to check APN settings of AT+CGDCONT? for 2G and 4G case.

Hi Sierra_klin1,
I have been using the same +CDGCONT details in both cases of 4G and 2G, I even tried different details from the WP7607 case also. Unfortunately this is still not working. Does the HL7692 module properly support 2G as I have found the below in the AirPrime HL76xx AT Commands Interface Guide

Hi PMcC,

HL7692 does support LTE Cat-1 (B3, B8, B20), GSM Band 900MHz and 1800 MHz.
The +CDGCONT support GSM as well.

I don’t know how your postman inits the connection with HL7692.
When HL7692 in 2G mode, I don’t know if you need to activate the PDP manually by AT+CGACT=1,1 to get the local IP address (Check IP by AT+CGPADDR=1).

Hi Sierra_klin1,

I have managed to solve this problem. It was down to a serious delay of 12 minutes for a TLS session to be opened using the HL7692 on 2G. However when doing this exact same operation using the same connectivity parameters on a WP7607 it takes 2 minutes to open a TLS channel. See below connectivity settings for each module. Is HL7692 supposed to be slower than WP7607?

HL7692 2G Connectivity.txt (160 Bytes)
WP7607 2G Connectivity.txt (131 Bytes)

Hi PMcC,

Good news that you manged to solve this problem.
Regarding the 12minutes delay, I cannot tell the exact reason without traces. But I guess some difference of retry mechanism when problem with the PDP activation or TCP communication.

Hi Sierra Team,
Can we have a follow up on this issue ? Can you attempt a reproduction Within Sierra Wireless Labs ?
This is affecting a smart meter customer using HL7692.

Hi Loic,

Sorry I may not understand your test case.
Could you let me know how to make the test?
Where you can see the 12 mins to make the TLS session?

For a normal HTTP with SSL test, it only takes me 5s to get the result.

AT+KSRAT=1 //2G only
+COPS: 1,2,“46000”,0
AT+KCNXUP=1 //21.03.2019 14:29:12.360
+KCNX_IND: 1,1,0 //21.03.2019 14:29:14.254
AT+KHTTPSCFG=1,“httpbin.org”,443,0,0, 1 //No authentication, only encrypt data
AT+KHTTPSGET=1,"/" //21.03.2019 14:29:24.001
HTTP/1.1 200 OK //21.03.2019 14:29:39.414. Only 5seconds to get the result.
Access-Control-Allow-Credentials: true