How to get UART2 working?


#1

Hi,

I am currently trying to get UART 2 working for issuing my AT commnads, but it doesn’t seem to be working at all, I have use the command AT+WMFM=0,1,2 and later AT+IPR=115200, when I switch the cables to UART2 there is no response from the terminal, any ideas.

Samuel


#2

Hi Samuel,

I think to switch IPR you must enter this command through the UART you would like to configure… Maybe try 9600 on terminal connected to UART2 first, if you can enter AT commands, do the IPR, then AT&W, then switch speed setting of your terminal emulator…

Best Regards,
Jan