How to discover a private LTE network

I have a problem with discovering a private LTE network with MC7430 module. The network is data-only and uses LTE band 1. Scanning for networks via QMICLI (–nas-network-scan) provides only the commercially available networks in Australia, such as Telstra (MCC/MCN: 505/01), Optus (MCC/MCN: 505/02) and Vodafone (MCC/MCN: 505/03).
What’s the catch in discovering a private LTE network?
Thanks in anticipation.

There are limited number of bands in LTE which are supported by a module , May be the band of the private LTE network that you want to connect is not supported by the module thats why the module is not detecting it.

You can view the list of supported bands in the PTS(Product technical Specification) of the module which you can download from

Thanks & Regards,


I have a problem something related to the same situation but a little different. Modem, EM7430 detects the private LTE network but doesn’t connect (actually doesn’t send any signal out). Is there some authentication or activation required ?


I am not able to figurout the root cause of the failure itself. When I try to start the network with
qmi-network -d /dev/cdc-wdm0 start , it fails with
error: couldn’t start network: QMI protocol error (64)

Could it be that network is not responding? Network is up and I could connect with another mobile. But not to the modem. Appreciate any leads or guess why the modem is failing to establish the connection.

Thank you.

Here’s some more information about the problem I have posted above:

When I scan the network with qmicli, I get my network listed. But when I use modem-manager and look for modem info, it does’t list any bearer. I tried to connect to the network using following command:

mmcli -m 0 --simple-connect=“apn=default,ip-type=ipv4v6” --verbose --timeout=1500

It fails accounting no response from the network. Should I set any routing table manually? I have stopped network-manager as I wanted to get over any interference and have edited /etc/network/interfaces:

iface wwan1 inet dhcp

I have tried to setup the modem with 3 different SIM cards.
Hope the info provided helps me to get some clue. Thank you.

I am not sure, but that error might be related to the protocol preference setting. Ref the hint from Tang here: … 01939.html

Or it could be any other mismatch between the parameters you request in your connection request and what the network allows.

Thank you for your inputs. I could get the modem to establish the connection with the network. It works with ip-type=ipv4v6.