HL7650 IP connection on Linux


#1

I have a HL7650 module on a Sierra dev board, connected via USB to a processor running Linux.

What I want is for the modem to appear as a network interface (eg. wwan0) so my Linux application can access the internet, with a serial port to control the module via AT commands.

When I first plugged in the modem, it appeared as 3 x CDC (ttyACM0, ttyACM1, ttyACM2) and 4 x network interface (wwan0, wwan1, wwan2, wwan3).

I tried AT+KUSBCOMP=2, and after power cycling, the modem showed as 3 x CDC and 1 x network interface (wwan0)

I then connected to ttyACM0 and set the APN and tried to connect:
AT+CGDCONT=1, “IP”, “m2m”
OK
AT+CGACT=1
OK

I got OK, and verified the IP address was valid:
AT+CGPADDR=1
+CGPADDR: 1,“100.115.157.144”

However, Linux doesn’t see any IP address on my wwan interface, and I can’t access anything using ping. I tried to run a DHCP client manually on the interface, but it just times out.

Can anyone please help me to resolve this issue?


#2

I just plugged the dev board into a Windows machine, and it worked. I was able to run a traceroute to a remote server over the cellular connection.

So it looks like the issue is one of configuration.


#3

When using KUSBCOMP =2, it is using MBIM interface.
Is that what you want?


#4

To be honest, I don’t know if MBIM is what I want.

What I want is for an interface to show up in Linux (eg. eth1, wwan0) that I can use to get access to the internet.


#5

I am using HL7690 (AT+KUSBCOMP=0) and I follow the document here:
https://source.sierrawireless.com/resources/airprime/application_notes_and_code_samples/airprime_hl75xx_network_interface_configuration_technical_note/

In Section 4, it teaches you how to connect in Linux.
It is working fine on my side.


#6

Thank you,

I was able to connect successfully to the HL7650 using the instructions in that link.

I have some further questions:

  1. Is there anyway to configure Linux to read the IP address and add the default route when the modem is connected?
  2. Is there a way to save the module configuration, so the connection is set up automatically on module boot?

#7

I think the easiest way is to write a bash script and check on /dev/ttyACM0.