MC7455 not bringing up WWAN interface

Hi, I have a MC7455 module in a Ubuntu 16.04 system. I am unable to see the WWAN interface and connect it to a test LTE network.

When I run:
sudo qmicli --device=/dev/cdc-wdm1 --device-open-proxy --wds-start-network=“ip-type=4,apn=cav” --client-no-release-cid

error: couldn’t create client for the ‘wds’ service: CID allocation failed in the CTL client: Transaction timed out

However a WAN interface is being created, just not shown in Modem-Manager:
sudo qmicli -d /dev/cdc-wdm1 -w

Any tips on how to get this running would be much appreciated.


Please check AT!USBCOMP? and AT!USBCOMP=? to see what USB interfaces have been enumerated.

How do I run the AT commands?

Below if the output of mmcli -m 0:
Hardware | manufacturer: ‘Sierra Wireless, Incorporated’
| model: ‘MC7455’
| revision: ‘SWI9X30C_02.24.05.06 r7040 CARMD-EV-FRMWR2 2017/05/19 06:23:09’
| supported: ‘gsm-umts’
| current: ‘gsm-umts’
| equipment id: ‘’

System | device: ‘/sys/devices/pci0000:00/0000:00:14.0/usb1/1-6’
| drivers: ‘qcserial, qmi_wwan’
| plugin: ‘Sierra’
| primary port: ‘ttyUSB2’
| ports: ‘ttyUSB0 (qcdm), ttyUSB2 (at), wwp0s20f0u6i8 (net)’

Numbers | own : ‘unknown’

Status | lock: ‘unknown’
| unlock retries: ‘unknown’
| state: ‘failed’
| failed reason: ‘sim-missing’
| power state: ‘on’
| access tech: ‘unknown’
| signal quality: ‘0’ (cached)

Modes | supported: ‘allowed: 3g, 4g; preferred: none’
| current: ‘allowed: any; preferred: none’

Bands | supported: ‘unknown’
| current: ‘unknown’

IP | supported: ‘ipv4, ipv6, ipv4v6’

SIM | path: ‘none’

Bearers | paths: ‘none’

I see clearly that the SIM is not detected.

Further now I see the WWAN interface but no IP is assigned:
wwp0s20f0u6i8 Link encap:Ethernet HWaddr 26:b9:93:d3:ab:e0
inet6 addr: fe80::24b9:93ff:fed3:abe0/64 Scope:Link
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:39 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:5507 (5.5 KB)

Let me know what is going wrong here. Thanks a lot.

you can use minicom on /dev/ttyUSB2 for the AT command port.

Google tells me that Ubuntu 16.04 comes with a 4.4 kernel. The features required for MC7455 support were added to the qmi_wwan driver in 4.5. Either upgrade your distro/kernel, use the GobiNet driver from Sierra Wireless or swithc to MBIM. I believe the cdc_mbim driver in 4.4 might work. But be aware that libqmi, libmbim and ModemManager all are pretty dated in a distro which was frozen more than 3 years ago.