HL7648 "code is invalid"

First time startup of HL7648 purchased from US distributor.
LTE type.
Both antennas are connected.
CREG reports it is connected to the network.
When I try to dial ATD[number] it immediately returns “BUSY.”

The following commands result.
xxxxxxxx means edited identifying info.

+CREG: 1,“FFFF”,“52xxxxxx”,7
+CGREG: 1,“FFFF”,“52xxxxxx”,7,“00”

According to the AT manual:
“FFFF” means the is location area code is invalid.
“00” means routing area code is invalid.

More command results:
+KSUP: 0
+COPS: 0,0,“xxxxxx”,7
+KCELL: 1,5,13xxxx,52xxxxxx,167,36xxxx,36,23,0

The codes signifying invalid parameters are related to the permanent BUSY when dialing. What is causing it?


Pretty sure that HL7648 is not VoLTE capable meaning that unless you are using AT&T or TMO and there is 3G coverage of the network in your area then it will not be able to place a voice call (I am presuming that you are not trying to do a PPP dial up with atd99**1#).



Yes, AT&T and 3G is used in this area. I tried to dial a common 1-800 number.

Hi @sales

It is OK for me with AT&T on HL7648. <;> Only required to set up voice calls. TA remains in command mode
I have attached the log file for your reference. HL7648.txt (998 Bytes)


+CLCC: 1,0,2,0,0,“8003310500”,145


Everything you show is very similar until the first ATD command. I see your AT+CEREG? command also gets you the “FFFF” and “00”

If I put the semicolon after the number I get an ERROR. I know that is required to dial after the ATD[number] for Telit modems.

I still get an immediate BUSY when I try ATD+8003310500 for example.
AT+CLCC gets an “OK” because there has been no last number.

I do have older firmware, I might try upgrading.

Hi @sales

Please upgrade it to the latest V04.02.A19 HL7648 firmware.

You can get it here HL7648 Firmware

Updated to V04.02.A19. No difference, still get a BUSY when I try to ATD dial out. I think this module must be incompatible with the local AT&T network.


The network across the US is universal and the modem is approved/compatible on said network. It is most likely the rights on the SIM card i.e. a data only SIM.

Couple of things to look at.

  • You could force it to 3G with at+cops=1,2,“xxxxxx”,2 where xxxxxxare the mobile country code/mobile network code which you can extract from the response to a network search (at+cops=?).
  • Check the APN configuration out with at+cgdcont? (we will ship the unit with the AT&T approved one but if it has been changed) if this is incorrect then it might be failing to attach to the IMS but still trying to place a VoLTE call.



I have just activating a new SIM card for the purpose of testing. No change in behavior.

When I try the suggested COPS command, it replies
“+CME ERROR: operation not supported”
That is because the HL7648 is an LTE only module.

I has the correct APN associated with the SIM card company. It has a valid looking IP address.
+CGDCONT: 1,“IP”,fp.com.attz",“”,0,0,0,0,0,0

According to a few cellular coverage maps, my area should be well covered by 4G.


If you are using an MVNO SIM I guess it depends if they support VoLTE (so namely an IMS)? Also when you attach to the network the IMS needs to be able to connect which is what the voice calls are routed through, have you configured this? It will generally have a different APN to the generic attach APN i.e. the normal AT&T APN is ‘broadband’ and the IMS one is different.

Your service provider should be providing you with all of these config details.



Reading the datasheet I am realizing this module does not support regular voice calls. I am looking for a North America 4G module that has CS voice capability because VOLTE is not everywhere yet.

And as you point out, the MVNO might not support it. Although Both MVNOs I have been evaluating say they support VOLTE on their webpages, my smartphone shows no indication it is active even though it is enabled.