HL6528RD network registration issues

Hello everyone,

I’ve been working for years with HiloNcV2 and later with HL6528RD. According to my experience, HiloNcV2 modems are not as good as any standard phone regarding connectivity (even with a good external antenna!).

For instance, I often face the case where old phone (eg. Nokia 3210) is able to attach/register a network quickly and with a good signal while HiloNcV2 either never connect or after a longer time. Obviously with same SIM card and at the same location.

Unfortunately, with HL6528RD it is even worse! Here is my last case:
I have one HiloNcV2 and one HL6528 RD with the same kind of external antenna both at the same location and both with the same operator SIM card (french operator Free).
The HiloNcV2 is able to attach an authorised roaming network quite easily with a good signal :

2019-10-11 06:44:46,16,7,V4:, …/trunk/serveurModem/outils/cmdAT.c(20956)read_from_modem()L172: RECV[0]:OK
2019-10-11 06:45:01,16,7,V4:, …/trunk/serveurModem/outils/cmdAT.c(20956)sendATcmd()L224: send[0]:AT+CSQ#015
2019-10-11 06:45:01,16,7,V4:, …/trunk/serveurModem/outils/cmdAT.c(20956)read_from_modem()L172: RECV[0]:+CSQ: 21,99
2019-10-11 06:45:01,16,7,V4:, …/trunk/serveurModem/outils/cmdAT.c(20956)read_from_modem()L172: RECV[0]:OK
2019-10-11 06:45:01,16,7,V4:, …/trunk/serveurModem/outils/cmdAT.c(20956)sendATcmd()L224: send[0]:AT*PSNTRG?#015
2019-10-11 06:45:01,16,7,V4:, …/trunk/serveurModem/outils/cmdAT.c(20956)read_from_modem()L172: RECV[0]:*PSNTRG: 5,1,“208”,“01”,“6901”,“2A9B”,“Orange F”,1,0
2019-10-11 06:45:01,16,7,V4:, …/trunk/serveurModem/outils/cmdAT.c(20956)read_from_modem()L172: RECV[0]:OK

On the contrary, the HL6528RD is able to attach this authorised roaming network only a few time and with a poorer signal. Most of the time it attaches a forbidden roaming network with an even worse signal (I can say that because the Hilo sometimes also attachs this forbidden roaming network that has a poorer signal):

2019-10-11 06:45:09,1,7,V4:, …/trunk/serveurModem/outils/cmdAT.c(20956)sendATcmd()L224: send[0]:AT+CSQ#015
2019-10-11 06:45:09,1,7,V4:, …/trunk/serveurModem/outils/cmdAT.c(20956)read_from_modem()L172: RECV[0]:+CSQ: 6,99
2019-10-11 06:45:09,1,7,V4:, …/trunk/serveurModem/outils/cmdAT.c(20956)read_from_modem()L172: RECV[0]:OK
2019-10-11 06:45:09,1,7,V4:, …/trunk/serveurModem/outils/cmdAT.c(20956)sendATcmd()L224: send[0]:AT*PSNTRG?#015
2019-10-11 06:45:09,1,7,V4:, …/trunk/serveurModem/outils/cmdAT.c(20956)read_from_modem()L172: RECV[0]:*PSNTRG: 6,2,“208”,“20”,“55F4”,“4E9D”,“F-Bouygues Telecom”,1,0,0
2019-10-11 06:45:09,1,7,V4:, …/trunk/serveurModem/outils/cmdAT.c(20956)read_from_modem()L172: RECV[0]:OK

I tried to change switch SIM card and external antennas and the behavior is always the same.

Both Hilo and HL are in automatic attach mode:

AT+COPS=0

I don’t know what I should do to make HL and Hilo register/attach better. Is it a good idea to try manual mode, given that my customers and I are not expert in GSM/GPRS network??

It is also worth mentioning that I experienced strange registration issue with Hilo already :

I also never had answer to my questions in those posts :

Is HL6528RD worse than Hilo? Should we switch to an other HL model?

Thanks in advance for your answers

Yesterday, I removed the HL652RD 1.8V from its socket and I have seen that some pins of the socket seem to have verdigris on the following pins : 49, 51 and 55.
I put a HL6528RD 2.8V in the socket and then the HL6528RD 1.8V back in the socket. I unplugged our controler for the night and this morning HL6528RD is attached to the authorized roaming network correctly and with a very good signal.
I suppose that there was verdegris adding impedance to the external antenna through PIN 49 TF_MAIN. Here encosed a picture with verdegris.

. The modem seems clean : 20191017_085755
This controller is in a heated room and its external antenna goes outside with a 2 meter cable. This antenna is IP 68. How could we explain that verdegris is coming?
Anyway, this seems that this particular case is solved but I still wonder how to optimize network registration/attach for hilo and HL in general. My initial question is thus still opened.

Hi,

Some pins of the socket have verdigris in a heated room because they are oxidized by high temperatures.
Please clean your socket and modem.
Can you check the signal network on HL6528RD with + CSQ command after cleaning the socket and modem?

Thanks,

Hi Donald,
Thanks for your reply
My modem has been working again for 2 weeks after removing the modem and cleaning the socket a bit.
The room in which the unit is exposed at the north in the north of France. The temperature never goes over 30 degrees for sure.
The only two things that are particular :

  • The unit (so the modem) is not powered at night and during week ends

  • The antenna IP68 is going outside : North side of the house, house is close to the sea so exposed to cold saled wind.

I’m looking for the possible reasons of oxydation for other sites problems
Best regards,
Thomas