GPRS connection stalls after 30-40 seconds


#1

Hi All,

Has anyone had experience using a Q2686 in Australia on Telstra’s NextG network? The modem registers and activates the context and I start pinging google.com over the PPP link. But after 30-40 seconds, the pings start to timeout. The PPP session continues to run but no more replies come from the internet. Also, I can’t ping the gateway once the problem occurs.

at+whwv
Hardware Version 4.03

at+wssw
B63f09gg.Q2686H 0026016CAA5DC7FF

I turned on some of the WIND and CREG notifications if that helps:

+WIND: 3
+WIND: 12,0
+WIND: 12,1
+WIND: 1
+CREG: 2
+WIND: 15,4,“09/01/12,22:59:17+40”,6,“0”
+WIND: 7
+CREG: 1,“3860”,“08EB”
+WIND: 16
+WIND: 4
+WIND: 10,“SM”,1,“ON”,0,“EN”,0
+WIND: 11,“405A664B39A4987C469D85327B26332D”,“8E4C3D548CF8586EE5E3E55227CA56C9”,“FE928EE04A5F0DF8C404C43E16FB1E9B”

at+cops?
+COPS: 0,2,50501

at+wopn=0,50501
+WOPN: 0,“Telstra Mobile”

I haven’t figured out how to do multiplexing to see what indications I get after the context is activated. Any hints on how to debug and solve this would be appreciated. Thanks.

Matt


#2

Does this help: viewtopic.php?f=53&t=2509#p11123 :question:


#3

Since yesterday, we tried changing to a different network operator (OPTUS) but have the same problem: the connection stalls after about 30s. I have tried adjusting some ppp parameters such as mtu but I’m pretty sure this is not a ppp problem since the ppp link keeps counting Rx/Tx and doesn’t report any errors, we just get no responses from the internet to any of our pings.

Today I will be trying our second Q2686 on a new board to check that this isn’t hardware related but since another engineer has reported a similar problem with a different Wavecom modem, I believe that this is going to boil down to an incompatibility between Wavecom modems and Australian GPRS networks.

Connecting COM2 may help but it will be difficult in my case because the device on which we have the Wavecom CPU attached hasn’t wired COM2 and doesn’t allow physical access to the connector. Even then, I’m not sure what commands to issue to debug the problem.

Matt


#4

This problem turned out to be a hardware problem. We unpacked a second CPU and plugged it into a new one of our host boards and the GPRS fired up straight away and stayed connected. I just ran some pings this morning and the connection is still solid. We are not sure whether the CPU was damaged or our host board.