Getting Started Document issues

Hi All,

I’ve been getting a dev system ready to start playing with the Legato module (which according to FedEx should be here tomorrow). I’ve found a few things that tripped me up, and (in my opinion) need to be changed in the provided Getting Started PDF.

I’m starting from a fresh download of Ubunto 12.04.3 desktop amd64

  1. The section Prepare development machine needs to be before the section Install Android Tools.
  2. The android tools need a java runtime installed to run - and no Java VM (JRE) was installed automatically with the Ubuntu install package I used. I had to do the following: sudo apt-get install openjdk-7-jre to install Java. Note that this is the ‘OpenJava’ JRE, not the genuine ‘Oracle’ JRE. More info on Ubuntu and the various JVMs can be found here
  3. The Android SDK referred to in the documentation no longer includes the ‘platform-tools’ download (which is required for both the adb and fastboot applications (referenced later in the document). To download/install these applications (and a few others), it is required to use the Android SDK update manager. This IS installed as part of the Android SDK (and why we need to install Java). To install the platform tools, do the following:
    [list=a][*]navigate to the directory where you installed the android SDK
  4. change to the tools/ directory
  5. execute the following sudo ./android sdk
  6. In the GUI application that opens, expand the ‘tools’ option and select Android SDK Platform-tools. Make sure that none of the other Android APIs are selected - we don’t appear to need them.
  7. Click on Install Packages to install the platform-tools to Ubuntu.
    ]Update the path to include the path to the platform-tools directory. Edit (using your favourite editor - I use nano) the file .bashrc and either update the path or add the following to the bottom: export PATH=${PATH}:/opt/android-sdk-linux:/opt/android-sdk-linux/tools:/opt/android-sdk-linux/platform-tools Remember to quote the paths if there are any spaces and note that I’ve installed the SDK into /opt/android-sdk-linux [/:m]
    ]When testing fastboot, it is required to use sudo to run it. The ‘Flash Images’ section of the documentation needs to be updated to show: sudo fastboot devices and similar, or you will get the unhelpful message fastboot: No such file or directory which at first look like fastboot had not been installed, or was corrupt in some way[/*:m][/list:o]

OK, that’s it for the moment.

Waiting to get the real hardware!

ciao, Dave


As discussed in this forum post [url=], it also appears that you need to have the IA32-LIBS package installed to get the Android SDK tools (i.e. fastboot) to run correctly when using a 64bit distribution.

sudo apt-get install ia32-libs

This needs to be added to the list of packages in the doco.

Hope this helps someone get going quicker.

ciao, Dave

Great feedback. Thanks.


Current recommended “long-term support” download seems to be 12.04.4:


Yep. 12.04.04 was released on Feb 6 2014 … I started this at the end of Jan, 12.04.03 was the LTS release when I started this.

Blast … do I start the process again with LTS 12.04.04, or continue with what I have (working).


ciao, Dave

Ha Ha -the joys of working at the bleeding edge…


You shouldn’t need to do anything. We’re using a mixture of 12.04 (32 and 64 bit), 13.04 and others to make sure our stuff works across most platforms.

The only real problems I have hit are with 13.10 and gcc 4.8 where the Yocto builds don’t work because of an issue with the EGLIBC version in Yocto 1.4.1. So you’re good.




Ciao, Dave

So I followed your lead

but that then becomes problematic:

awn@lap-tosh-01:~$ cd /opt/android-sdk-linux bash: cd: /opt/android-sdk-linux: Permission denied
cd doesn’t work with sudo:

I can use sudo su to get a root shell, and reach the tools folder:

awn@lap-tosh-01:~$ sudo su
root@lap-tosh-01:/home/awn# cd /opt/android-sdk-linux/tools
execute the following[code]
sudo ./android sdk

But the command doesn’t work:

root@lap-tosh-01:/opt/android-sdk-linux/tools# ./android sdk bash: ./android: Permission denied root@lap-tosh-01:/opt/android-sdk-linux/tools# sudo ./android sdk sudo: ./android: command not found

Where am I going wrong :question:

(remembering I’m a complete *nix novice)

Hi Andy,

you probably want to own the android tools as your own user rather than having to use root. To change ownership you should do:

sudo chown -R /opt/android-sdk-linux awn

I’m assuming that awn is your user.

Hope that helps.

As (at least some of) the grief seems to be due to permissions on /opt, I tried installing to /usr/local instead - and that worked OK.


Another difference was that I had previously decompressed the download on Windows, and then copied across on a USB stick - because the Ubuntu GUI Archive Manager gave me grief about permissions for the /opt folder, and I didn’t know the command line way.

This time, I found - which gave me the command line to decompress:

 tar -xvzf android-sdk_r22.6.2-linux.tgz