FXT009 - sending special characters via email using WIPFILE


#1

Hi all,
I’ve got problem with sending special characters using AT+WIPFILE command during SMTP session. When I received email special characters are repleaced by ? sign (question mark). Standard ASCII signs are OK, only special characters are changed. Special characters come from polish alphabet. If somebody knows the reason please for advice, how to resolve this issue. Thanks in advance.

My modem. FXT009 , firmware R7.47.4.20120831…


#2

Hi,

Are you using terminal application to read the content?
If so, I think the problem maybe the terminal application does not support that charset so the special character was displayed as “?”.

I am not familiar with polish alphabet, but I guess “Ń” is one:
http://www.isthisthingon.org/unicode/index.phtml?glyph=0143

Below my example using +WIPFILE with WIP Soft v532:
On hyper terminal, it was shown as:

? ? e?

? ? ?

But the raw data captured seems to be fine when I read using text editor:

Ń ń eń

Ą ą ą

[attachment=0]mail-test.txt[/attachment]

Hope it helps.
L


#3

Thanks Lotam for your reply

More details: I wrote application in .NET using AT commands to send SMS and e-mails. Everything works fine, but exactly there is problem with polish signs, which you mentioned in previous post. I have received e-mails using Post Windows Live. I tried to change encoding in post app, but nothing’s changed. In a message source there is still “??? - test” instead of “ęąćśź - test”. Below there are list of commands:

+WIPFILE=6,1,2
CONNECT
ęąćśź - test
ETX
OK

In e-mail source I’ve got ???. I tried to receive e-mails using different post application, but final effect is the same. Have you got any ideas how to resolve this problem ?


#4

Hi,

I am confused whether you want to send special character or you need to receive it? It can be problem on getting input from user or display it…

As you are using .NET and you mentioned you changed the encoding in post app… can you share that?

Again, I am not familiar with the special character, but in my test using c#, it can send the special character(“Ń”) to UART after I added below:

port.Encoding = Encoding.GetEncoding("utf-8");

Hope it helps.
L


#5

Hi,

Lotam - that is solution. It works beautiful. Great thanks.

BTW, the same like you I’m not familiar with special characters, but that was my customer’s request. Thanks to you this problem is resolved. Good luck!