FX30 Cat-M - no network service - legato and ppp connect OK

I have FX30S LTE - M/NB-IoT units I am testing and am
not able to get data session through host up using AT!SCACT.

I recall in the past being able to use WP modules to connect to cellular network
in three different ways:

  1. using legato cm connect (internal legato connection)
  2. using ppp (host connection via serial port)
  3. using scact (host connection via USB)

I am able to successfully connect usign methods #1 and #2
above usign two different FX30S devices and two different SIMs / data plans.

I am not able to get the SCACT connection to work with either one, however.

The AT!SCACT=1,1 fails with:
+CME ERROR: no network service

I have updated FX30 firmware to the latest FW on Sierra Source
REl 14

The APNs are correct for the SIMs / data plan(s).

The module shows registered home NW very strong signal strength

I read through all the forum posts I could find on both the legato and Sierra forum sites
I was not able to find a solution.

I tried using another PID than default PID 1 (i.e. PID 2)
with corresponding change in SCACT command but with the same result.

I have tried SELRAT = LTE only and AUTOMATIC
and have looked at AT!SELCIOT. It was set to LTE M1: 0x02
which allows it to register on the NW. I tested the others but it
doesn’t register with them. I would expect M1 to be correct.

I tried SELRAT 00 and 06. The result is always the same failure.

Please advise as to how a connection over USB using AT!SCACT can be accomplished.

Are you testing in linux enviorment?

You can see here: