Fwupdate reports "Error in download"


#1

I’m not able to update my FX30 using “fwupdate download boot-yocto-legato_wp85.cwe”. I was able to update when the FX30 had the factory installed legato framework which was actually 16.10.1, not 16.10.1.m3. I rebuilt the framework using the yocto project. That produced a boot-yocto-legato_wp85.cwe file. I updated to the new image without any problem, but now i cannot update using any other .cwe files. I’ve tried boot-yocto-legato_wp85.cwe and boot-yocto_wp85.cwe.

Here’s the output when i try:
root@fx30:~# fwupdate download boot-yocto-legato_wp85.cwe
Connecting to service …
Download started …
Error in download

Here’s the logread -f output:
Jan 6 22:37:29 fx30 user.err Legato: =ERR= | fwupdateDaemon[574]/swiQmi T=main | swiQmi.c swiQmi_CheckResponse() 781 | Sending QMI_SWI_M2M_FDT_WRITE_REQ_V01 failed: rc=-49 (x), resp.result=0.[0x00], resp.error=0.[0x00]
Jan 6 22:37:29 fx30 user.err Legato: =ERR= | fwupdateDaemon[574]/swiQmi T=main | swiQmi.c swiQmi_CheckResponse() 781 | Sending QMI_SWI_M2M_FDT_CLOSE_REQ_V01 failed: rc=-49 (x), resp.result=0.[0x00], resp.error=0.[0x00]

Here are my versions:
root@fx30:~# cat /etc/legato/version
Build created at 2019-01-21_11:05:39

Yocto build version: SWI9X15Y_07.12.09.00

Build host: ubuntu
Versions:

  • firmware: SWI9X15Y_07.12.09.00
  • poky: yocto-1.7.3-29-gc282df8
  • meta-openembedded: 70beecb
  • meta-swi: e65c639
  • meta-swi-extras: 796df54
  • linux-yocto-3.14/meta: 961ca71325
  • linux-yocto-3.14/machine: ab5094eade
  • meta-mangoh: b58ad3c
  • meta-columbia: R14.0.4.002_modified

root@fx30:~# legato version
16.10.1.m3_c5f0b6f608b59be779cbd2c101604e13_modified

What causes this sort of issue and what does the log output mean?


#2

Hi @jrm06c

Could you please try the following:

  1. Try this command: cat boot-yocto-legato_wp85.cwe | fwupdate download -
  2. If that doesn’t work, download the full official R14.0.4.002 bundle from the Source and try the fwupdate command (https://source.sierrawireless.com/~/media/support_downloads/airlink/software/fx30/r14.0.4.002/mcu-rmfw-boot-yocto-legato_wp85.ashx?la=en)
  3. Try using fdt2 tool or swiflash
    https://source.sierrawireless.com/resources/airprime/software/fdt/
    https://source.sierrawireless.com/resources/airprime/software/swiflash/

If all these fail, lmk and there is a procedure to perform a recovery, but you’ll need to remove the case.

BR,
Chris


#3

I was able to flash the factory image using method 3 of your response.

I tried 1 and 2 but neither worked for me.

Also, I’m using a linux VM hosted by a windows PC. I think this was causing a problem for the swiflash utility. I tried using it, but it got stuck on downloading firmware. The ellipsis continued for a long time before i terminated the attempt. For anyone else wondering, the download should happen in a matter of seconds or less. Here’s the output when it was not working:
Detecting USB of the target
DONE
Communicating with the target
DONE
Switching to firmware download mode

Everything worked fine when i tried the FDT utility on my windows host. Here’s the output when it worked:
FDT version: 1.0.1806.0
Awaiting suitable port or adapter …
Switching to streaming mode …
Downloading images …
Writing image
Flashing image
Awaiting adapter …
Checking update status …
Enabling selective suspend …
Firmware image download succeeded.
Final Firmware update succeeded.

Preexisting images information:
Current:
Firmware:
ImageId:
BuildId:
Configuration:
ImageId:
BuildId:
Final images information:
Current:
Firmware:
ImageId: 001.033_000
BuildId: 07.12.09.00_GENERIC
Configuration:
ImageId: 001.033_000
BuildId: 07.12.09.00_GENERIC

OEM PRI: 9906645 01.02

IMEI: 353984080455411

Total time elapsed: 133656 ms.

Images downloaded:
Image ID: 001.033_000
Build ID: 07.12.09.00_GENERIC
write time: 5657 ms
additional flash time: 19843 ms

Time to reset to application mode: 102094 ms.

Press Enter to continue …