first problem?


#1

i’ve just downloaded and ran expresso.

the problem i’m encountering is:
at first boot expresso tries to find a wavecom product on a serial port.
but i already have com1 open in another program (no wavecom product attached anyway)

  • expresso doesn’t let me change the comport!

ok. the above isn’t a problem, but rather an annoyance.
after pressing the disconnect ? ( come on. the program isn’t even connected!) button i can choose an other comport.

also, after entering my PIN for the sim the dialog keeps stating “Your SIM Card has been detected but a PIN Code is necessary.”

at first glance… looks ok to me :slight_smile:

even though i’m not the intended audience. (using a Q26 devboard) :stuck_out_tongue:


#2

That would be really annoying! :angry:

It is highly likey that I would have other serial ports in use and with non-Wavecom devices attached - it would be totally unacceptable for any application to go messing with the serial ports without being specifically requested to do so! :angry:

I’m sure I said that in the Beta forum…


#3

well. it’s certainly not messing with them (it can’t the os prevents that)
it’s just that it is a unnecessary hang-up in the startup of the program.
if you can’t connect to it then first try the other ports for availability.
if you can’t find any device on an open com-port (or if no com-ports are available) then start bugging your user about it


#4

True.

I was thinking more of devices that are physically plugged-in to a COM port, but not actually with any application (yet) using it.
Sorry, that wasn’t clear.

It causes enough grief when stuff like XP tries to scan ports for serial mice at startup - Wavecom really should know better!


#5

The difficulty we have here is that Expresso is targeted at users unfamiliar with wireless modems and we wanted Expresso to be as “automated” as possible in every aspect. The desire was to prevent a user from having to figure our which port [physical or virtual] they had connected to and avoid having to explain how to find this in the system area of the windows control panel.

Note that we have taken the original feedback in to account on “do not port scan” and Expresso does not do this. What it does do when it starts is try to find a Wavecom compatible device on the last port used so if you used it on COM13 the last time, it will look here first and if it doesn’t find a Wavecom product, it doesn’t look on any other ports and will display the connection dialogue for you to manually configure the port. Obviously, if this is the first time to run Expresso, it will look on COM1 and then display the connection dialogue if it doesn’t find a compatible device.

We would still like to implement a “port scan” feature but this would be manually initiated from the connection dialogue.

So, back to Madouc:

I hope this is ok with everyone?


#6

the thing i found problematic is that:
when you tried the com-port , and you couldn’t connect for whatever reason, you shouldn’t claim you’re connected! and make the user press the disconnect button before he/she can select the right com-port.

perhaps if you present the user with a choice the first time the program runs?
1 let expresso search for the modem
2 let the user decide which port expresso looks at


#7

Understood. Yes, the 3 step connection approach can lead to a step 1 (physical connection success) without a step 2 (device recognised success) so I suggest we change that to:

if step 1 = true and step 2 = false then disconnect

We’ve noted this and will take a look at the most appropriate way to implement with a 0 option = search on last successful port only (1 = search all available ports = long time on some machines!)

Thanks!


#8

Sounds like a good solution

If this is the first start, there is no last successful port or previously used port.

Also, if you target your program towards an inexperienced userbase you might consider changing the following sentence for the connection dialog on first start:
“You tried to communicate with your target, but you are not connected.”
Into something like:
“Expresso tried to communicate with your target, but it could not connect.”
The first sentence makes it sound like I’ve done something wrong.

Happy to help you create better software :slight_smile: