File corruption after reset


#1

I am testing file system sample.

Occasionally the files created got corrupted after reset (at+wdwl, at+cfun or power cycle). File lengths are correct, however the contents become all ones - 0x0ff.

Is this a known issue or am I missing something?


#2

Hi,

What is the module and the firmware version you are using(i.e. 7.50 or 7.51) at your end. Also can you please provide the information about exact steps used i.e. how the application is being used with AT commands(can you please provide the AT commands issued).

Does the file get corrupted after one reset or many resets.

Thanks.


#3

Thanks,

I am using FXT009
Install OS 7.51 using DwlWin
Set WOPEN=6,1024 and WOPEN=9,1024
Install file system sample usind DS-2.2.1
Create file tree by using FS=32 command
Check contents with FS=8
Issue command WRST=“000:10” and leave overnight.

This post was ment “is it just me or…”. Seems it is only me. I am currently out of office, but will check issue with other module next week and post result here.


#4

Hi,

I have the same problem, I got 0xFFs, but it is not related to Reset, sometimes reading the file for the xth time, it becomes corrupted. Not only the file beeing read, others too. File lengths, names, dates are OK.
File handling is done by sw, not with AT commands.

Thanks


#5

I did check with other device with the same result, file contents were erased.

I’ve shelved 7.51 and file system, waiting for better times.


#6

Now testing with 7.52…


#7

7.52 solved.


#8

Nice to hear!

Do you have any Release Notes of FW 7.52?

best regards
Gregor


#9

I had the same issue.
Does not seem related to reset.
I managed to isolate it to be related to the UART drivers and some combinations of USB2UART cables.
The files are corrupt after download.
Workaround I managed downloading the files using USB, no corruption at all.

FYI: After upgrading FW & OS I no longer have the issue.

Cheers
P


#10

Really B7.52, and no release notes, yet.

br