FCM GPRS Subscription with Firmware R71


#1

hello,

I’m testing for a couple of days the new firmware version R71 and WIPLib version 401, and
have noticed some significant changes / strange effects comparing with the old one.

I’m using the Wireless CPU Modul Q2687h with latest Firmware R71 and WIPLib 401 with the SDK 2.02.

I’ve writen a program that subcribe to the GPRS-flow.
The modul is still used as GPRS-Modem using AT-WIP-commands.
I only want to listen to the incoming GPRS-datastream.
In the old Firmware version this worked very well. The only thing to consider was, that a ‘Slave-subscription’
was necessary.

Now, in the new one, this program gave me an negative return (-5) of the fcm-subscription when I’m using
the ‘Slave-subscription’, so I tried to remove the Slave one, and do a ‘normal-subscription’ and it worked now,
giving me an zero return, which means to me, that the fcm subcription don’t fail.
But after a while about 10min, the Modul reset with an ‘ARM Data Abort’ Error.
But before this Error I’ve received some Data from the GPRS Flow, so I don’t understand why this Error suddenly appears.

Maybe someone have still tried this, and could help me with it.
Or anyone else have some ideas what’s going wrong here.

Thank you.

Kind regards
HW