Error 38 Network out of order


#1

On a Q2687 when I try to send a short message using adl, I get the following error:
CMS ERROR: 38, Network Out of Order.

The strange thing is that I get the error only when my application is running. I can use the AT+CMGS command or the adl_smsSend command and they both give me the same result. If I stop the application however and run AT+CMGS, it works fine, after CPIN of course.

My app connects to the bearer and then to a socket on our server. I can disconnect the socket, but I still get the error. (connected or not shouldn’t actually present a problem.

Wha??


#2

Does your application set an invalid Service Centre Number?

Are you using PDU mode?
If so, maybe there’s an error in your PDU?


#3

Sorry I guess my EMail advisor was turned off, so I hadn’t seen this.

Anyways it seems to be only applicable to one or certain of our boards.

I’ve checked Service Center number, and I’m using ascii. All the wireless CPUs are the same “burn” both in firmware and software.

I haven’t gone into detail on the standard header configs etc. The ones that work, work with default configs.

I’ll just keep plugging along. I’ve only found one (board) that gives the error, but have only tested 3. with different combinations of SIMs
across the 3. To make matters worse, the provider hadn’t properly configured all the SIMs, although that “problem” was filtered out in
the testing of all SIMs in all boards.

If anything interesting comes up I’ll give a holler.


#4

what maybe that one modem uses another type of registration ?
you might check AT+CREG? and AT+CGREG?
to see how the modem is registered on the network.