EM7565 Wake Host on SMS message not working


#1

I am attempting to use the AT!CUSTOM=“WAKEHOSTEN”,1 setting to configure an EM7565 module to wake up our embedded Linux i.MX6 host upon the receipt of an SMS message, however I do not see any change on the WAKE_ON_WAN# line (pin 23) when we send the module an SMS text. I have tested this in both normal power with AT+CFUN=1 and low power with AT+CFUN=0. The WAKE_ON_WAN# is default pulled up to 3.3V by external circuitry.

We also enabled SMS notification using AT+CNMI=1,1,0,0 and we notice that there is no +CMTI asynchronous notification of an incoming SMS in low power mode. When we switch back to normal power we do see the +CMTI messages after about 15 seconds. Our system design depends on the EM7565 module being able to receive an SMS in low power mode and wake up the Linux host.

We are currently using Release 11 of the AT&T certified firmware. Our FAE indicated that the WAKEHOSTEN customization was supported in this firmware. Is there some additional configuration setting that we are not aware of?

Appreciate your support,

grace


#2

Hi grace

I tried the same. So far without success. Did you have more luck by now?
If so ? What is required to get it up and running?

Regards

Fabrice


#3

@ipetronik,

Yes we did get it working with a little help from our FAE. First off, you do not need to set the module in low power mode via AT+CFUN=1. That actually puts the module in airplane mode with no RF enabled. The module follows the LTE DRX/DTX standard where it will autonomously enter a power saving mode if no call or data session is active, and periodically wake up (~2-3 seconds?) and check with the network for activity. The module and the network carrier configure/enable this automatically.

Secondly, when “WAKEHOSTEN”,1 is set, the module will only assert WAKE_ON_WAN# when the host is actually suspended. We were testing with the host at full power and thus never saw the wake signal.

Thirdly, like most embedded engineers, they provided a backdoor “debug” setting of “WAKEHOSTEN”,0x81 that will assert WAKE_ON_WAN# whether the host is active or suspended. Using this setting, we successfully received the wake signal, which is a 1 second active low pulse.

You also must have the latest(?) Release 11 of the firmware.

Good luck!

grace


#4

Hi grace,

thanks for your reply. But I just can not get it to work. It looks like the module does not receive the SMS at all. Does the module need more settings here? I’ve read from another thread that an AT+CNMI = 1,1,0,0 could help. Unfortunately not for me. Incidentally, I used Release 12. Any further ideas?

Regards

Fabrice