Em7565 upgrading problem

I have a problem after upgrading firmware from ancient 00.03.05 to higher version. Modem upgraded successfully to 01.14.02 but stuck on boot and hold (1199:9090).

Bus 001 Device 010: ID 1199:9090 Sierra Wireless, Inc. EM7565

I’m unable to revert to old firmware because i don’t have it. So i grabbed a log from dram. It says that it’s unable to find FOTA partition and some nv items are incorrect. Most interesting things are:

B - 425078 - hw_family:2, hw_type:2, hw_rev:16
B - 450119 - idsflashinit, could not get FOTA partition name
B - 460672 - Failed to read size: /swinv/item_files/CUST_IM_SWITCH_HIDE
B - 465826 - Failed to read size: /swinv/item_files/CUST_NETWORKNAMEFMT
B - 467931 - Failed to read size: /swinv/item_files/MBIM_CUSTOM_DATACLASS
B - 480466 - Failed to read size: /swinv/item_files/LOCK_ROOT_ON_BOOT

I see several ways to fix it.

  1. Revert to old firmware or oldest release, like 01.00.02. How could i get old firmware?
  2. Download whole flash. I have appropriate bin file but i have no idea, how to manage that. I made several downloaders for qualcomm based devices long time ago (msm5xxx, 6xxx) and i know that i need tsr loader for that. I don’t have such for this chipset. The question is how to write whole flash image or where to get tsr loader/programmer?
  3. Repartition the device. How could i make it?

p.s. i’ve tried 01.05.01, 01.07.02, 01.08.04, 01.09.04, 01.11.00, 01.14.02, 01.14.05 with same result.

Thanks a lot for help

Hi @fantasia.ended

Which PC’s OS you use, Windows or Linux?
After power cycle, is the device turn on?
The EM7565 device connect to PC over USB 2.0 or USB 3.0?
If USB 3.0 is used, you can try to upgrade over USB 2.0.


Thank you for reply.
I’ve tried linux/win/win server with native usb 2.0, 3.0 through 2.0 hub, 3.0, direct m.2.
Modem is in the same state always except one case - when i download 01.05.01, it switches to USB_BULK device with same 1199:9090

Hi @fantasia.ended

The your case is upgrade from the FW older than release 9, It have mentioned on Customer Release note https://source.sierrawireless.com/resources/airprime/minicard/75xx/em75xx-swi9x50c-crn-release-note/#sthash.xBxdxX6x.dpbs.
You can refer to it at page 61 for more information.


Thank you for advise. LPM is not the same with “boot and hold”. Modem is not in offline but in qdl mode. It responses on limited number of dm commands and sahara later.

Does anyone know the jtag pins for em7565?

Hi @fantasia.ended

You can try to install FW 01.05.01 on the device, and then upgrade the the device to latest FW twice.
Or, you can refer to the topic [Solved] EM7565 Firmware Update from to for more information.