EM7455 No NEMA Port

I have a few Getac laptops running Windows 11 with the EM7455 module. I need a serial port for my AVL software. There is no NEMA port showing. Just the geolocation sensor, modem, NM Port, Qloader (hidden), and the NIC. I have removed the factory drivers and used the Sierra ones with no success. I found a few articles for other devices with a similar issue, but none of that advice worked. There are no devices missing drivers in device manager.

If anyone has suggestions I would appreciate it. Thanks in advance.

what is the response of the followings:


I got it to work after trial and error. I changed USBCOMP=99 to USBCOMP=8 in the install config file. I had to run the installer and manually remove the existing drivers a few times until the installer installed all of the devices including the NEMA port.

I now noticed it broke the cellular some how. It shows under network adapters. I can’t rename it from “cellular” and it shows no Verizon service. Back to drivers uninstall/install. I replaced the cellular NIC driver by itself with no success. I may have to engage GETAC as the config file has a lot of settings that may be screwing this up.

did you check the AT command response like AT!GSTATUS?

Sorry. Haven’t dealt with SW modems in over a decade. A bit rusty,

That AT command returns-
Current time: 2744
Reset counters:1
Mode: Low Power Mode

The not being able to rename the adapter was a Win 11 bug. Can’t right click and rename on this PC…have to select rename connection for some reason.

I flashed the firmware again today (did it yesterday) and it now seems to be happy. Thanks Again.

Edit: GPS is now retuning NEMA sentences with no fix. Researching that.

Still no progress. My NEMA output has NEMA sentences with no position. AT!GPSSTATUS? Returns no fix. It had fail code 9 and then 12 and eventually got no fix. It has been consistent with no fix. The Getac geolocation show no fix or satellites in their G-Manager tool. I also tried the AT command for satinfo and it saw none. I’m going to try the SSD in another unit to rule out a bad card or antenna.

If anyone has input I would appreciate it.

Solved. Changing the install from USBCOMP=99 to USBCOMP=8 got the NMEA port installed. Still had no GPS and the header was found loose from the factory. Secured that and got a GPS fix on the geolocation sensor only. NMEA still had no fix or fail. Had to do the RMA reset on the modem. That defaulted the modem to ATT firmware for some reason despite having a VZ SIM. Flashed the firmware and cellular was back. Still no NMEA data. Did an AT!reset reset and now have data on the NMEA port.