Diasable RING indication


#1

Hi friends,
Is it possible to disable the unsolicited result code “RING” during incoming call?

regards
roy


#2

With or without your own Open-AT application?


#3

Hi

Check the AT command guide for at+wrim. It might do the job…


#4

No, this command just defines hardware Ring signal mode.


#5

But the AT Commands Manual is certainly the place to be looking for this information…


#6

Certainly…
At least Q24 manual have nothing at this point.
RING indication can be blocked by ATQ1. But nothing can stop CONNECT or NO CARRIER messages.

With open AT application some other options available, NO CARRIER can be dealed with.
But CONNECT behaviour is one BIG BUG. I know one method to disable it, but only at the cost of other problems.


#7

I wouldn’t call it a bug.

It is, effectively, a “Solicited” response - it’s what confirms the transition from command mode to online mode.

Without the CONNECT indication, you would have no way to know when you’re actually connected…

:question:


#8

Really? :slight_smile:
Anyway, i mean other bugs.

  1. With anabled autoanswer (S0=1+) CONNECT can’t be blocked even with ADL_CALL_NO_FORWARD return from CSD handler. Not deadly, but wrong.
  2. Manual answer (S0=0) by adl_callAnswer(): CONNECT reported after disconnect even in “Connect encapsulated as data” mode (+WBHV).
  3. Manual answer by adl_callAnswerExt() with straight UART specification: CONNECT missing at all.
    And some other minor issues. Again, it’s Q24 + 6.57g/h FW. Maybe new 7.xx firmware on Q26xx works better.