Detection of CONNECT for an auto-answered call


Hello All,

I’ve got an Open AT application that monitors data calls, but is having trouble detecting when a connection has been established. This only occurs when the external application is in auto-answer mode (ATS0=1). I can see the “CONNECT xxxx” message on the terminal emulator, but no event is being passed to the callback function subscribed using the adl_callSubscribe function.

Any ideas? :confused:


Hi Richard
If you have the auto answer on then your call handler wont have time to answer the call and take control of the call.
I have 2 different solutions
in the adl_main send adl_cmdcreate “ATS0=0”
and the second one is to subsribe to unsolisited “connect” to catch the call.
Best regards


You can use ATS0=, > 0 version of the command to get additional time.


Err… just a minute…

ATS0 is a setting for the Wavecom software - not the external application!

In Open-AT terms, “External Application” refers to the thing outside the Wavecom unit.

Setting S0=1 causes the modem itself to auto-answer - so the External Application doesn’t have to!

Perhaps if you explained what you’re actually trying to achieve, then people could offer more informed suggestions?