Devices List don't show COM port in Windows 10


I Have update my computer in windows 10. When I run Developer Studio -> Target Management. I can’t see Devices List,
You can help me.

Kien Tran

Developer Studio is not officially supporting Windows 10 yet.
We are currently on integration phase, targeting to provide this support for next release.

I have exactly the same problem. Is there any workaround to access the ports in DevStudio under Windows 10?

We’re investigating on the issue.
As soon as we have a workaround (if possible), we’ll post it here.

Hi all,
it sounds that we’re not reproducing the problem here.
Our test configuration:

The driver is installed correctly:

And the port is displayed in DS, working correctly.

Please can you check the driver is installed correctly?
If yes, is it possible to launch DS in debug mode to grab some more logs?

  • Download the attached debug.txt file
  • Create a shortcut to “devstudio.exe -debug debug.txt”
  • Launch DS
  • Once it is started, please grab the “.metadata.log” file, zip it and post it here
    debug.txt (330 Bytes)

I have the same problem on Win 8.1 and Build Version The debug information shows

java.lang.UnsatisfiedLinkError: no rxtxSerial in java.library.path thrown while loading

Please can you provide some more information:

  • Windows edition: 32 bits or 64 bits?
  • Java version + edition?
  • Eclipse configuration: please dump configuration from Help > About DS > Installation Details > Configuration into a file, and attach it here
  • What installer did you use to install DS 2.3.2?

Having this issue as well.

Using 64 bit Windows 10.
Java 8 Update 60.
Developer Studio 2.3.2

Full error is

log.txt (728 KB)
ds-configdump.txt (284 KB)

I was using the full installer. Re-installing with the fast installer fixed it.

Windows 64 bit. Java 1.8.0_60-b27. Configuration file attached.

configuration.txt (473 KB)

Got it. But take care: it installed DS 3.5 (i.e. working only with FW 7.5X)

Concerning Developer Studio 2.3.2, we reproduced the problem and we have a workaround.
Actually, the integrated version of Eclipse simply doesn’t know anything about Windows 10 and Java 8 as it is too old. But it’s not possible to install any other Java version on Windows 10.
The root cause of the problem is that DS is not able to resolve the path to the native DLLs it needs to access to the serial ports.

The workaround:

  • Create a folder named dlls in Developer Studio folder (e.g. C:\Program Files (x86)\Sierra Wireless\Developer Studio\dlls)
  • In this folder, copy the 2 rxtx*.dll files you can find in \plugins\\os\win32\x86
  • Open the \plugins\ with an archive manager program (e.g. 7-zip), and extract the libUSBNotifier.dll file to this folder as well
  • Edit the \m2mstudio.ini file, and add the -Djava.library.path=C:\Program Files (x86)\Sierra Wireless\Developer Studio\dlls argument at the end of the file, on a new separated line

You can then start DS, and the serial ports should be displayed again.

I can confirm the workaround resolved the problem for me. I can now see ports in DS. Note I had to change one of the steps as I didn’t need to unpack anything:

(1) Exit Developer Studio

(2) Open the Developer Studio installation folder in file explorer, e.g. [b]C:\Program Files (x86)\Sierra Wireless\Developer Studio[/b]

(3) Create a folder named dlls in Developer Studio installation folder, e.g. C:\Program Files (x86)\Sierra Wireless\Developer Studio\dlls

(4) Copy rxtxParallel.dll and rxtxSerial.dll from plugins\\os\win32\x86 to [b]dlls[/b]

(5) Copy libUSBNotifier.dll from [b]plugins\[/b] to [b]dlls[/b]

(6) Edit m2mstudio.ini and add the dll folder as a Java library path to the very bottom of the file, e.g.

-Djava.library.path=C:\Program Files (x86)\Sierra Wireless\Developer Studio\dlls

(7) Launch Developer Studio

My environment details where this workaround resolved the problem:

Windows Edition: Windows 10 Professional 64 bit
Java Version: JRE 1.8.0_60-b27 32 bit
Installer: OpenATAFOnlineInstaller_v2.3.exe
Dev Studio Edition:
SL8 Driver Version: 11.5.1005.5

That worked great, thank you.


Same issue on Windows 8.1 but:

There is no folder when you install Developer Studio 2.3.2.

You need to install Developer Studio 2.3.2, then install Developer Studio 3.5.
You can retrieve from the directory where DS3.5 is installed.
And following the given procedure.


There may not be a folder, but there should be a jar with the same name, which you can open as a zip file.


This method is help for me:
(On Windows 10 & Developer Studio 3.5:)

1.: Copy (Install dir)\DeveloperStudio\plugins\\libUSBNotifier.dll to [i](install dir) \DeveloperStudio\plugins\\os\win32\x86[/i] folder
2.: Add the last path ([i](install dir)\DeveloperStudio\plugins\\os\win32\x86[/i])to the Environment variables PATH. :
(Control panel > System > Advanced System Settings > Environment Variables > System variables > Path ( > Edit and add new…) )
3.:Restart Windows