Datacall


#1

I quote:

I have to add that I am fairly new to OpenAT and even the use of modems in general.
I managed to make a datacall from a hyperterminal to the SiWi modem.
Using the developer studio, I answered the call with ATA wich seems to set up the connection. In the terminal I receive “CONNECT 9600”.

At this point I’d think that Im able to type and send data from and to the SiWi modem but I don’t seem to receive these characters in the console view of developer studio. Is this because I am still in AT mode?
If so, how do I change to data mode?
Or did I understand this completely wrong and do I need to use the FCM to receive the data from the GPS flow and resend it on the serial link?


#2

Yes - you should.

Does it work if you just use a simple terminal program (eg, Hyperterminal) instead of DS?

No.


#3

Now I do receive the “connect 9600” in hyperterminal, through the SiWi modem.
The characters i send from the SiWi modem arrive well on the other modem/terminal.
The characters that I should receive are not displayed.

Both terminals are configured for 115200 baud, since thats what they need when performing AT commands. I tried changing both to 9600, gibberish.


#4

Ok it works as it should, very easy.
Just had to have everything running at the same baud rate


#5

You shouldn’t actually need to have everything at the same baud rate - but it certainly simplifies things!


#6

I have the similar problem with you jorn :

In the SiWi DS console view, nothing appear and I can’t send any data (only can send AT command to the local modem),
but in the other terminal side the character is appear (only CONNECT 9600).

Then I try to use cutecom (linux hyperterminal like program) at the both side, and it works, the character is appear in both direction.

Is there any specific setting for DS ?

I try to similize the baud rate setting, but still can’t works.


#7

Sounds like a limitation of DS, then :question:

I suggest that you make a post in the DS forum - with a link to this thread - about this…


#8

I believe that when you are connected to the modem, with DS, then DS will try to keep the modem in AT mode.
Even though my application is supposed to switch to datamode, when I reset my application in DS through cfun = 1 or wopen = 0 /1, the modem restarts but remains in AT mode.

This is rather annoying, I have to remove any battery from the device that uses the modem to reset it and have it run in data mode.

Edit:
The same problem remains when I reset the modem through a terminal instead of through DS, so this is not a DS issue but an Open AT one.


#9

This is not a flow control (RTS/CTS, +IFC) problem, is it?


#10

I guess not, or do you have reason to think so?
Are you experiencing the same problem?

I am connected in DS, by the traces I know that I get to the point where the modem should switch to data mode, but it remains in AT mode


#11

This is because DS issues the at+wdm command which is used to switch the modem into development mode. When the modem is in development mode, the port will always be available in AT mode.

If you want to make a datacall from within DS, then go to Target Management and click the “Production Mode” button in the left panel where you choose your com port.


#12

Oh thank you Kaare for pointing that out. This makes things a whole lot easier.
How long does it remain in development mode then? Is it another AT command to switch back to Production Mode?

Thank you


#13

You can switch between the two modes with the two buttons in the panel at the left side. You can also control the mode manually with AT+WDM=<0 / 1> where 1 = development mode and 0 = production mode.