Can't make http request ( GET,POST or PUT) with wifi module BX3100


I currently use a wifi module BX3100 to make http requests with APIs, I validate the tcp ip communication mode, but I can’t do GET or POST over HTTP via http servers to test.

here is the scenario via UART :

Terminal => AT+SRWCFG=1,3
Rsp => OK

Terminal => AT++SRWSTACFG=xxx,xxx
Rsp => OK

Terminal => AT++SRWSTACON=1
Rsp => OK
Rsp => +SRWSTASTATUS: 1,“JPB_2.4GHz”,“a0:ab:1b:8f:05:10”,9,3
Rsp => +SRWSTAIP: “1xx.xx.1xx.11”,“”,"1xx.xx.103.2xx

//configure http sesion

Terminal => AT++KHTTPCFG=“”,80
Rsp => +KHTTPCFG: 1
Rsp => OK

//Start http sesion

Terminal => AT+KHTTPCNX=1
… it’s take few seconde …
Rsp => +CME ERROR: 906


i don’t understand why i have this error ! cab sole one help ? thanks

Best regards,


Hi @jawaddidouh

You should configure http session AT+KHTTPCFG=, instead of AT++KHTTPCFG=“”,80

It works well at my side.
Please find the log file for your reference.
A_BX_EmbeddedSW_HTTPGET_0002.txt (4.1 KB)

If the issue is solved, could you help to mark “Solution”? So that the community can easily find the solution for their problems.

1 Like

Thanks @Donald !

Have you an exemple of how write HTTP HEADER with “Authorization” ?

When i make :

 Terminal => AT+KHTTPHEADER=1
 Authorization : Bearer  eyJ0eXAiOiJKV1QiLCJhbGciOiJIUzI1NiJ9.eyJpc3MiOiJodHRwOlwvXC9zb3BoaWEuZGV2LWtleXByb2QuY29tXC9hcGlcL2xvZ2luIiwiaWF0IjoxNTc5NTA2MjM4LCJleHAiOjE1Nzk1OTI2MzgsIm5iZiI6MTU3OTUwNjIzOCwianRpIjoicko1MmU3Z2JXM\r\n
 Rsp => OK 

But when i snd the request, i have server error, and i’m sur it’s about how i’m writing the header with " KHTTPHEADER=1 "

Hi @jawaddidouh

As the original issue has been solved. For another issue, you should create another new ticket for easy tracking.