Cannot access board through UART1 anymore, or USB

So I was attempting to manipulate the Sample code for UART echo, because I was having trouble sending data through any of the UART’s, and I seem to have lost my ability to access the board. Every time I try and open the port or connect I get a timed out error.

What I had done is take the sample echo uart code and changed everything in the code to work for uart2, instead of uart1 (because using the usb has nevered worked for me I’ve never been able to sort out the drivers). And now I appear to be locked out of using uart1 to do anything with the board including sending AT commands through the TMconsole.

Has anyone heard of this happening? I haven’t been able to find any other posts of anything similar and was looking for suggestions of things to try.

I’ve already tried to access the port through hypertermials, out side of M2M.
I’ve tried opening the ports with M2M.
I’ve of course tried resetting the device, I am curious if there is a hard reset other than the button on the side of the board that I don’t know about yet.

–Thanks, hopefully someone has some ideas for me.

Hiya,

Which module and which board?

Ciao, Dave

… Oops, my bad. AirPrime, Q26 series, specifically Q2687, with the q26 development kit V3.2.

This might help as well, I went back to see if I could load hello world onto the board, and the errors I get are:

Preparing the target for launch => ERROR: Time out: 20000ms
Open and load physical port COM1 => ERROR: Time out: 20000ms
Open port COM1 => DONE: Success
Open port COM1 => NO NEED TO DO IT: Success
Load informations from target => ERROR: Time out: 20000ms
Waiting for module detection => ERROR: Time out: 20000ms

This is with the settings of 115200 - 8 - none - 1 - hardware settings.

What was the result :question:

Hiya,

Sounds like your application has managed to lock UART1 so that the internal AT command processor cannot get access to it.

If you have the dev board, then you should be able to use DWLWin to erase the application (or indeed reflash the whole module).

First thoughts: (DO THIS AT YOUR OWN RISK!)

  1. Download DWLWin from the Developer Section of the website. While you’re there, grab the release notes for the latest version of firmware for Q2687 as there instructions inside the doc about how to use DWLWin.

  2. Install DWLWin onto your PC

  3. Turn off the power to your Dev board, and set the BOOT switch to ‘ON’.

  4. start DWLWin, set the serial port settings as required to talk to your dev board. Make sure that there are no firmware updates checked (you probably won’t have any in the three top windows), and make sure that ‘Application’ is selected in the ‘Erase’ box (to the right of the serial port settings).

  5. In DWLWin, click the ‘Start’ button, then power up your dev board. You should see the green progress bar start with the message 'Downloading firmware loader (or similar). Once this completes, the progress bar will restart with the message ‘Erasing objects’. Wait for the Status message ‘Process Succesful’.

  6. Close DWLWin, power off your dev board and set the BOOT switch back to OFF

  7. power up your dev board and see if you have AT commands on UART1 afain.

Hope this helps.

ciao, Dave

Time to remember the old trick of a Startup Delay before your app does anything - so that you have time to stop it before it locks you out…:confused:

https://forum.sierrawireless.com/t/faq-forum-wiki/3491/5

https://forum.sierrawireless.com/t/modem-reset-continuously/4489/3