c-gps and wipsoft problem


#1

I’m using the fastrack supreme 20, and I need to get the position with GPS, I have activated the feature, I’m working with c-gps simplesample opus I, and I need to use the wipsoft too, everything compiles fine but when I download the fastrack returns “memory allocation error”. I searched for help but found nothing.

when I have the C-GPS opus I ready I add the header include “wip_atcmd.h” and function wip_ATCmdSubscribe (); I think it works well but I make the mistake of memory allocation.
if I run the example “C-GPS Opus I” and “wipsoft” separate works right.

What am I doing wrong?

regards!!!


#2

hello, i do it, i get the fix in gps but when i send at+wipbr=4,6,0 (start bearer, gprs, client) returns +cmee error: 811, searching in the manual this error happens when the sim isn’t ready, sending at+cpin? returns +cpin ready.

what is happening?

for the last error i send at+wopen=6,128 and all runs fine, the problem was the memory.

regards!!!


#3

Before bearer service started successfully, GPS service must be disabled. In another word, if you start bearer first and wait for ADL_SIM_EVENT_FULL_INIT event, then initialize GPS.
Good luck.


#4

See also: https://forum.sierrawireless.com/t/q2686h-firmware-r74-at-wdwl-problem-solved/3839/15