BX3105 BLE keeps advertising after a connection

I’m having an issue where the BX3105 is allowing more than one connected device.

with one device (smartphone) connected to the BX3105, the UART works fine
with two or more devices connected to the BX3105, the UART stops working.

Having more than one connected device is not our goal, i just want one device connected at the same time. I have read at the config guide the following “Advertising stops automatically when a BLE connection is established”. But this is not happening.

Here are the config used for the module:
AT+CGMR
AT+CGSN
AT+MACADDR?
AT+SRWCFG=3,2
AT+SRBTSYSTEM=2
AT+SRBLE=“VIRTEC_VL8_0071”,517,1,128
AT+SRWAPCFG=“aaaaaa”,“aaaaaaaaaaa”,4,0,0,100
AT+SRWAPNETCFG=1,192.168.0.10,192.168.0.11,192.168.0.12,120
AT+SRBLEADDSERV=1800
AT+SRBLEADVPARAMS=32,64,0
AT+SRBLEADV=1
AT+SRBTSTATE=1,2
AT+SRWSTADNSCFG=“8.8.8.8”,“8.8.4.4”,“8.8.8.8”
AT+SRBTNAME=“VL8-MARTE_0071”
AT+SRBTCPROFILES=1

Any ideas on how to force it to disable advertising, or to only allow one connection at the time?

how about AT+SRBLEADV=0 after one device connected?

The device im trying to configure its quite closed source, i cant program anything on it (to send AT+SRBLEADV=0 after a device is connected). so im bypassing it (and ESP32) and configuring the BX3105 directly,

What i need to do is to refuse any BT connections if one is already estabilished. currently it is allowing more than one connection on BT Classic, and this is causing the TX to be moved between devices, causing issues.

I also didnt managed to implement a PIN, im using AT+SRBTCPINCFG=1,5555 but this is not requiring pin to connect.

If you cannot send or change AT command, i don’t know what you can configure

I can send AT commands direclty using a USB-Serial adapter, what i cant do its modify a program (from another MCU talking to the BX module) to send data over AT.

If i can limit the amount of sessions to 1, or only allow one connected BT device at the time, it would fix my problem. Any ideas?

How about making it not discovered by other device?

It would work, but how?

Using “AT+SRBLEADV=0” after a connection is made? or is there any AT that can handle it automatically?

how about using AT+SRBTSTATE to set non-discoverable?