Bug with low baudrate on serial port


#1

We are using Q26RD with Fw 7.44. The modem is connected to our main device through UART1. Its main functionality is to download (From server to the device) a unique file which size is about 1Mo / 1.5Mo. The trick is that, in this design, we have to use a « low » baudrate between the modem and our main device.

I did a test with this configuration:

  • Developpment kit connected to a PC (HyperTerminal) trough UART1
  • Baudrate on UART1 : 1200
  • No OpenAT application
  • Flux control : Not relevant (I’ve tried with and without)
  • Downloaded file size : 1Mo

After a few bytes received (between 45Ko and 90Ko in my case) the modem resets. I don’t know why : Watchdog or internal buffer overflow ?
Same test with baudrate = 115200 runs perfectly.

Does anyone saw the same behavior? Is that a known bug?
How can I walk around? I’d may reduce the GPRS dataflow but I don’t know how to do so…

Thank’s for help.

Here’s a trace :

at+wipcfg=1
OK
at+wipbr=1,6
OK
at+wipbr=2,6,11,"my_apn"
OK
at+wipbr=2,6,0,"my_login"
OK
at+wipbr=2,6,1,"my_pwd"
OK
AT+WIPBR=2,6,12,1
OK
at+wipbr=4,6,0
OK
AT+WIPCREATE=2,1,"my_ip",my_port
OK
+WIPREADY: 2,1
at+wipdata=2,1,2
CONNECT
<my_http_request>
HTTP/1.1 200 OK
Date: Thu, 28 Apr 2011 06:46:01 GMT
Server: Apache
Last-Modified: Fri, 24 Dec 2010 08:32:48 GMT
ETag: "2000000009649-13d620-49823d4c9643d"
Accept-Ranges: bytes
Content-Length: 1300000
Connection: close
Content-Type: text/plain

/File content/

/Software reset/

#2

Hi
Did you change the baud rate by issuing AT+IPR=1200 command and save it using AT&W command or you just changed the baud rate in the settings of hyperterminal?

Regards
Paruthiv


#3

I’ve changed both and saved with AT&W prior to any test.