Booting from USG issue on MG90


#1

Hello,

I encountered an issue while booting MG90 from USB.

The only info I have is output from console

MG90 U-Boot 2015.04 (Apr 12 2017 - 14:19:34)
MMC: Clock=300000000 MaxBusW=0 f_max=52000000 FSL_SDHC: 0
*** Warning - bad CRC, using default environment

PCIe1: Root Complex x1 gen1, regs @ 0x3400000
01:00.0 - 168c:003c - Network controller
PCIe1: Bus 00 - 01
PCIe2: Root Complex x63 gen15, regs @ 0x3500000
03:00.0 - 168c:003c - Network controller
PCIe2: Bus 02 - 03
In: serial
Out: serial
Err: serial
Net: eTSEC2 [PRIME]
QE upload: Firmware ‘Microcode version 0.0.1 for LS1021a r1.0’ for 1021 V1.0
QE: uploading microcode ‘Microcode for LS1021a r1.0’ version 0.0.1
QE init complete
Hit any key to stop autoboot: 0
starting USB…
USB0: Register 200017f NbrPorts 2
Starting the controller
USB XHCI 1.00
scanning bus 0 for devices… 1 USB Device(s) found
scanning usb for storage devices… 0 Storage Device(s) found
switch to partitions #0, OK
mmc0(part 0) is current device

Partition Map for MMC device 0 – Partition Type: DOS

FS Volume Name Part Start Sector Num Sectors UUID Type
ext2 rescue 1 40960 1126400 00000000-01 83
ext2 rootfs 2 1167360 2568192 00000000-02 83
oMG Slot Info from MCU…
slot 0: ord=0
slot 1: ord=0
slot 2: ord=0
slot 3: ord=0
desired boot ord=0
current config ord=0
max config ord=0
booted DPI=0x00000000
Not initialized, so default will take effect: slot=1
Boot: ext2 on mmc 0:2 [/dev/mmcblk0p2]
** File not found /boot/uImage **
=>

What could be the reason?

Thanks for any info and best regards,
Bogdan