BC127 refuses to exit data mode


#1

Hi,

I’ve been working with the BC127 for a few months now and for the life of me can’t figure out how to ask the BC127 module to exit data mode. I have an SPP connection established and want to make sure I can regain control over the module and change parameters/get data using command mode. The scenario I’m trying to account for is if a user renames the BC127 module from the mobile app I’m working on.

  1. Some command is sent to the microcontroller (a Teensy 3.6 in my case), ex: changeName:<name-here> using the BC127 module’s data mode.
  2. the microcontroller sends the exit-data-mode sequence $$$$ to the BC127 module
  3. the microcontroller waits for the OK response
  4. when received, changes the BC127 device name
  5. and finally asks the BC127 to re-enter data mode with the previous spp connection once the name is changed

Does this command flow sound ok?

My command currently looks like delay(500); _serialPort->print("$$$$"); delay(500);, and my CMD_TO value is at it’s default value of 20.

I’ve tried all sort of carriage return/newline combinations and flushing the serial port before and after. I’ve also tried disabling GPIO control and driving GPIO_5 LOW to exit data mode, which also didn’t work? All I should have to do is drive GPIO_5 LOW to exit, right? After disabling GPIO control of course. Is there something I’m missing there? Ideally I’d be able to exit data mode with this pin.

I’m currently rocking Melody Audio v6.1.5 HD w/ build # 1496941831.

Any help would be appreciated!!

Best,
Drew


#2

Hi,

Your command sequence seems to be OK. There is one similar issue fixed in BC127 Melody Audio 7.1. Please upgrade the FW and see if this can resolve the issue.

You can download BC127 Melody Audio 7.1 on Source:
https://source.sierrawireless.com/resources/airprime/software/bc127-firmware/


#3

Yep that was it! Thanks for your help.


#4

Looks like Melody 7.2 has the same bug at the moment.