BC127 pairing with car (16 digit PIN)


#1

Hi,

I am trying to open an AGHFP connection with my BC127 DISKIT to a Skoda Octavia (2011) with the stock radio (Columbus). Firmware is the latest Melody version, 7.2, Build 1534785311.
But I already fail when trying to pair with the car. In another car (Kenwood radio), pairing and AGHFP work fine, there is no need for confirming a PIN.

  1. Pairing initiated by the car
    The car finds the BT module, but quickly after showing the 16 digit PIN, it immediately cancels the pairing process. The BT module stays in state PAIR_PENDING. No PAIR_PASSKEY notification is shown, no matter which SSP_CAPS setting (0,1,2,3,4,5) is used.
    Is a 16 digit PIN even supported by Melody?

  2. Pairing initiated by BC127
    When initiating the pairing progress through the BC127, the car shows the PIN input prompt. But when I enter 0000, the UART prompt shows PAIR_ERROR and aborts. (PIN=0000 on the BC127).

Is there anything I am missing?

Here is the configuration:

config
AUDIO=0 0
AUDIO_ANALOG=15 15 1 OFF
AUDIO_DIGITAL=0 44100 64 100A00 OFF
AUTOCONN=0
AUTO_DATA=OFF OFF
BALANCE=100 100
BATT_CONFIG=OFF 145 4250 1500 150
BC_SMART_CONFIG=68E3 28F0 89F7 D93C ON
BEACON_DATA=0 00 11 22 33 44 55 66 77 88 99 AA BB CC DD EE FF 04 D2 16 2E EE
BLE_CONFIG=0 OFF 80 ON
BLE_CONN_PARAMS=128 12 24 40 0 400 100 400 400 64 400 400
BT_STATE_CONFIG=1 1
BT_VOL_CONFIG=A 60 10 1
CLASS_1=OFF
CMD_TO=20
COD=5A020C
CODEC=0 OFF
DEEP_SLEEP=OFF
DEVICE_ID=0001 0002 0003 0004 0005 0006 0007 0008
ENABLE_BATT_IND=ON
ENABLE_LED=ON
ENABLE_SPP_SNIFF=OFF 0 0 0 0 0
GPIO_CONFIG=ON 0
HFP_CONFIG=OFF ON OFF OFF OFF OFF
HIGH_SPEED=OFF OFF
LOCAL_ADDR=20FABB0A003F 000000000000
MAX_REC=2
MM=OFF OFF 0 OFF OFF OFF OFF OFF
MUSIC_META_DATA=OFF
MUSIC_OLD_AVRCP=OFF
NAME=test
NAME_SHORT=BC0A003F
PIN=0000
PROFILES=0 1 0 1 1 0 0 1 0 0 0 0
REMOTE_ADDR=000000000000
SPP_UUID=00 00 11 01 00 00 10 00 80 00 00 80 5F 9B 34 FB
SSP_CAPS=3
TWS_CONFIG=OFF 1 2
UART_CONFIG=9600 OFF 0
USB_HOST=OFF
VREG_ROLE=1
OK

Every help is appreciated, thank you in advance!


#2

Hi.
I also have similar symptoms in the Renault model.
(All device settings are the same as above.)

The following message is displayed.

Bluetooth authorization failed
The passkey you entered is wrong
Try the authorization process again.

Does anyone fix this problem?