BC127 inquiry pair


#1

Hello,

I would like to know if there is a way to auto connect/pair with the most high inquiry value device at startup with an empty pdl?

thank you


#2

@fred128,

When you say the most high inquiry device what do you mean? The one that is broadcasting the most often? If so then there is no way for the unit to easily determine what this is as it is luck as to when the unit will see it. Also the unit will only automatically reconnect to a device it has previously connected to (assuming you have autoconn set to 1). After this it has to be commanded to connect to something or something has to connect to it.

Regards

Matt


#3

Thank you for your reply.
I mean, the device which has the higher dB level when an inquiry is performed.
But you say it has to be in the paired device list if I want an autoconnection?, or I have to send a command?

In this case, I have an other question : I set autoconn and the remote_addr for my device to be reconnect to, but when I send get remote_addr, the address is a little different : af20123456789 become af20123467890005 or something like that.
I can’t get auto reconnect to this address.
Is it a format problem?

thank you


#4

@fred128,

So if the unit can see a device when it has powered on with autoconn set to 1 then it will automatically connect to it, it will connect to devices in the order that they are in the list.

For the second question you are going to need to give me a log file showing the initial pairing and the subsequent power up with the

Also if you can send the below commands in addition to the commands needed for the sequence that would give me a base to figure out what you might be seeing.

version
status
config
list

Regards

Matt


#5

Thank you.
I can’t do it now but I will send you what you need tomorrow.
In the mean time, is it enough to set autoconn=2 and remote_address=BTAddress? Or the BTAdress has to be in the list of paired devices?

thanks


#6

@fred128,

The unit has to be in the list of paired devices so that the have previously exchanged keys for the link to be secure.

Regards

Matt


#7

Hello,

Here the log:

set remote_addr=20FABB044832
OK
write
OK
get remote_addr
REMOTE_ADDR=20FABB48320004
OK

version :

Sierra Wireless Copyright 2018
Melody Audio V7.2
Build: 1534785311

status : (also tried bt_status_config=0 0)

STATE CONNECTED[0] CONNECTABLE[ON] DISCOVERABLE[ON] BLE[OFF]

config :

AUDIO=0 0
AUDIO_ANALOG=15 15 1 OFF
AUDIO_DIGITAL=0 44100 64 100A00 OFF
AUTOCONN=2
AUTO_DATA=OFF OFF
BALANCE=100 100
BATT_CONFIG=OFF 145 4250 1500 150
BC_SMART_CONFIG=68E3 28F0 89F7 D93C ON
BEACON_DATA=0 00 11 22 33 44 55 66 77 88 99 AA BB CC DD EE FF 04 D2 16 2E EE
BLE_CONFIG=0 OFF 80 ON
BLE_CONN_PARAMS=128 12 24 40 0 400 100 400 400 64 400 400
BT_STATE_CONFIG=1 1
BT_VOL_CONFIG=A 60 10 1
CLASS_1=OFF
CMD_TO=20
COD=240404
CODEC=6 OFF
DEEP_SLEEP=OFF
DEVICE_ID=0001 0002 0003 0004 0005 0006 0007 0008
ENABLE_BATT_IND=ON
ENABLE_LED=ON
ENABLE_SPP_SNIFF=OFF 0 0 0 0 0
GPIO_CONFIG=ON 0
HFP_CONFIG=OFF ON OFF OFF OFF OFF
HIGH_SPEED=OFF OFF
LOCAL_ADDR=20FABB0447FB 000000000000
MAX_REC=2
MM=OFF OFF 0 OFF OFF OFF OFF OFF
MUSIC_META_DATA=OFF
MUSIC_OLD_AVRCP=OFF
NAME=BC-0447FB
NAME_SHORT=BC0447FB
PIN=0000
PROFILES=0 0 0 1 1 0 0 0 0 0 0 0
REMOTE_ADDR=20FABB48320004
SPP_UUID=00 00 11 01 00 00 10 00 80 00 00 80 5F 9B 34 FB
SSP_CAPS=3
TWS_CONFIG=OFF 1 2
UART_CONFIG=9600 OFF 0
USB_HOST=OFF
VREG_ROLE=1

list :

LIST 20FABB044832 A2DP AVRCP

Otherwise, if I set autoconn=1, it connect automatically.

thanks

edit: if the device has to be in the pdl, the autoconn 2 is a little useless, as autoconn 1 is enough. But maybe someone needs that feature.

In this case, is it possible to set a paired device list? I saw it was in connection library on pskey 45 but I don’t understand the format : 20fa bb04 4832 3401 0004 5008 96cd cb65 03dd 478a 6b87 ec2b dc81

edit2: I just saw that after a reset, the remote_addr is removed, I get 000000000000 instead

edit3: The autoconn 1 works when I run a reset, but if i reset the remote device, the autoconn doesn’t work and neither the autoconn from the remote device as the source become undiscoverable.


#8

@fred128,

I stand by my previous statements.

  • The unit needs to be connected to the device previously to auto connect to it again.
  • The unit will operate from the paired devices list and will connect in order.
  • You can cannot manually add devices to the unit for it to automatically connect to.

Regards

Matt


#9

Ok thank you, that’s clear now.

There is only one thing left :
With 2 device connected, when I turn off sink device, then turn on back, the source doesn’t reconnect automatically and seems to become undiscoverable. I have to turn off then on the source too.
Is it the only way?

thanks