BC127 Auto Connect with AUTOCONN=2 not working


Hi there,

I’m trying to reconnect using the AUTOCONN=2, but it doesn’t work for me.

I tried it with a mobile phone (HFP) and a BLE device. I paired them both, so they are in the Paired Device List (PDL).
But when I manually set the remote address, then WRITE and RESET the bc127, it does not autoconnect to the defined address. Nothing happens on console except the start-up code (…READY). But the configurations stayed permanent, the AUTOCONN and the REMOTE_ADDR is set.
If I use AUTOCONN=1 it’s working, but I want to have control which device shall reconnect, e.g. not the phone but the BLE device.

Maybe the following is related to the problem: When I read the REMOTE_ADDR parameter, it not only showing the BT address. The HFP device’s address is followed by 002A, the BLE by 005A:

Is this just a internal mechanism to save the profiles of the paired device?

How can I establish a reconnect / auto-connect after reset with AUTOCONN=2?

I’m using Melody V7.2.


REMOTE_ADDR Corruption?

no idea? this implementation must have been tested somehow



The autoconn only affects BTC connections and not BLE