AT+WSCAN=<freq> command always reports "+CME ERROR: 3"


#1

From documentation:

[i]Wavecom Scan +WSCAN

Description
This Wavecom proprietary command displays the received signal strength indication for a specified
frequency (in absolute format).
This command is not allowed during communication.

Syntax
Action command
AT+WSCAN=
+WSCAN:
OK

[/i]

What the phrase “This command is not allowed during communication” means? I try to use this command and in “dedicated mode” and in “idle mode”, without a sim card, and even when the modem is not registered in a network. Neither in GSM, nor in UMTS this command does not wish to work. Persistently produces “+CME ERROR: 3”. How to be?


#2

i’ve always interpreted this as ‘not during an active gsm/gprs/utms session’.

in my modem (using 7.4a firmware) i can use at+wscan=50 without error while sim is disconnected and also while sim is active.

what parameter do you supply to the function?


#3

Value were set in limits from 0 to 65535. In all cases (all values from this range got over) calls with these values were completed with an error. Presence, or absence of a sim card does not influence in any way result.


#4

unless your sim-card is obscuring your antenna in some way :wink:


#5

madouc!

I simply submit power supply on the modem without a sim card. I wait some minutes while the modem will boot, and I start AT+WSCAN=50 command. In the answer - ERROR. No active sessions like would be present. Perhaps something needs to be changed in a modem configuration?


#6

This happens to a single modem?
do you have other modems where it does work?
is an open-at application running on the modem? (check with at+wopen=7, answer should end with 0 or 1)
do other commands work on this modem?
what is the firmware version?