ADL_SIM_EVENT_FULL_INIT


#1

When i call the function: adl_simSubscribe. I get the following events:
ADL_SIM_EVENT_INSERTED and ADL_SIM_EVENT_PIN_OK.

I don’t get ADL_SIM_EVENT_FULL_INIT. My program has been working for about a month now but it stopped working last weekend. Can anyone tell me how i can make the Fastrack Supreme to issue the ADL_SIM_EVENT_FULL_INIT ? because without it my GPRS and HTTP transmissions no longer work.


#2

What is your OS version? Did you change SIM card or operator. We’ve seen a very long time till ADL_SIM_EVENT_FULL_INIT for a certain operator for OS versions earlier than 6.57f.


#3

My OS is v6.21. I have been using the same SIM card and the same operator (Vodafone Netherlands)


#4

Maybe your SIM card just died…


#5

Also I’ve never seen OS version 6.21.


#6

I have tried 3 other SIM cards from the same operator but i have the same problem. However, The SIM cards are working well in my phone.


#7

The SIM and operator are definirely not the problem. Can someone tell me how to solve this problem please ?


#8

are you able to update the firmware?
i’ve got no problems with vodaphone nl’s sim-cards, but i’m using 7.3


#9

Hi…

Are you in any case using RTE mode…?? i remember an issue where the ADL_SIM_EVENT_FULL_INIT event is not received with RTE mode. Or may be your SIM is getting registered pretty fast and hence the event is missed. You could try with enabling the SIM PIN which will provide some time for the SIM to get registered which in turn would help in the event being received.

Hope it helps… :smiley:
Regards, Paruthiv


#10

Yes, it is certainly true that early events - including SIM events - can be missed when in RTE mode.

Have you tried enabling the WIND indications - they also show you the progress of SIM initialisation…

See also: viewtopic.php?f=44&t=931&p=3330&hilit=FULL_INIT#p3330