Accentuated characters

i have a problem with accentuated characters, so when i send a sms (with comand or with adl function) with some accentuated characters, in the destination mobile they doesn’t appear or they appear with an other caracters.


Hello malek,

GSM units use a standardized GSM character table over the GSM network (7 bit characters) and another character table when communicating on the serial interface. The GSM character table contain all english characters and also support for different language specific characters. But since those characters are not represented with the same hex values as in each “normal” countryspecific character table (such as Nordic or German language settings in Windows), we need to use this CUSTOM character table to map the GSM character table to the specific language,

For example, if you want to use the German special character ü and Ãœ, you have to change the character set in the Wavecom unit. This is done by using the “CUSTOM” character set in the modem.

Change to CUSTOM character set with the command:


Then you have to modify both character tables CUSTOM_TO_GSM and GSM_TO_CUSTOM.

Table CUSTOM_to_GSM:
Character Ü and ü

AT+WCCS=1,0,220<enter>           /* Character Ü */

AT+WCCS=1,0,252<enter>           /* character ü */

Table GSM_to_CUSTOM:
Character Ü and ü

AT+WCCS=1,1,94<enter>             /* Character Ü */

AT+WCCS=1,1,126<enter>            /* character ü */

But you need to change the CUSTOM table to the values you need for the accentuated characters.