a problem with FXT009


#1

Hi, all!
Sorry, I bad speak on English (((

I have a problem with FXT009 - I can not remove applications.
at+wopen=0
OK
at+wopen=3
ERROR
at+wopen=4
ERROR

In what there can be a problem? Help me please.
Thanks.

PS:
ati3
R7.46.0.201108091301.FXT009 2216044 080911 13:01

at+wipcfg=3
WIP Soft v542 on Open AT OS v636
Jul 13 2011 13:31:51 WIPlib:v5a37 WIPSoft:v3b28


#2

Turn on error codes to see what errors are being thrown:

AT+CMEE=1

If the application and flash have already been deleted, an error will occur so make sure you haven’t already deleted the application. Check using

ATI9

#3

I want to delete the application/flash and to upload applications of other version

at+cmee=1
OK

at+wopen=0
OK

at+wopen=4
+CME ERROR: 532

at+wopen=3
+CME ERROR: 548

ati9
“DWL”,“V08b11”,"",“Sierra Wireless”,55236,“122210 15:25”,“e8a16b54”,“00010000”
“FW”,“FW_SRC_746_8.Q2687RDG”,“R7.46.0.201108091301.FXT009”,“Sierra Wireless”,2216044,“080911 13:01”,“2f1beedd”,“00020000”
“ROM”,“800000”
“RAM”,“200000”
“DWLNAME”,“FXT009”
OK


#4

If you look in the Codes and Values section of the AT command user guide, you will see that CME Error 548 is “No flash objects to delete”, and CME Error 532 is “the embedded application is activated so the objects flash are not erased”, but this is also returned if there is no application at all.

The ATI9 command shows application information. If there is no application information returned in ATI9, then there is no application stored on the unit.

You don’t have to erase the application before downloading, just download the new one on top. You will only need to clear your flash objects if you have changed the format of what is stored there, or you want to delete all stored settings.