5G network scan with the EM9191: operation not allowed

Hey all,

I’m trying to do a 5G-only network scan with a EM9191 module, running firmware 03.04.03.00 GENERIC_030.012_000.

I’ve configured all 5G bands in the module:

AT!BAND=0C
OK

AT!BAND?
Index, Name
0C, NR5G ALL
OK

And I was hoping that triggering a standard network scan, it would return the list of available 5G networks in the area, but instead I’m getting an error:

AT+COPS=?
+CME ERROR: operation not allowed

Using QMI and “NAS Network Scan” also fails:

$ sudo qmicli -d /dev/cdc-wdm0 -p --nas-network-scan
error: couldn't scan networks: QMI protocol error (70): 'InvalidOperation'

There doesn’t seem to be any 5G around :slight_smile: as the module doesn’t report anything in NRINFO:

AT!NRINFO?

!NRINFO: 
Connectivity Mode: ---
Connectivity Mode: ---
Cell ID:         ---
NR5G band:       ---            Carrier Index:   ---
NR5G dl bw:      ---            NR5G ul bw:      ---
NR5G Rx chan:    ---            NR5G Tx chan:    ---
NR5G dl MIMO:    ---            NR5G ul MIMO:    ---
NR5G(sub6) RxM RSSI (dBm):   ---                NR5G(sub6) RxD RSSI (dBm):   ---
NR5G(sub6) RxM1 RSSI (dBm):  ---                NR5G(sub6) RxD1 RSSI (dBm):  ---
NR5G(mmw) Rx0 RSSI (dBm):    ---                NR5G(mmw) Rx1 RSSI (dBm):    ---
NR5G RSRP (dBm): ---            NR5G RSRQ (dB):  ---
NR5G SINR (dB):  ---
OK

But I hoped I would at least get an empty returned list instead of an error. What’s the correct way to perform a 5G-only network scan?

I’m probably mistaken or missing something. For 5G NSA EN-DC, I understand the LTE anchor is first required, so LTE bands would have been needed. But if I configure only 5G bands, wouldn’t I be able to search for 5G SA networks?


BTW, the module is configured to select any access tech, I didn’t change that. I only change the selected bands:

$ sudo qmicli -d /dev/cdc-wdm0 -p --nas-get-system-selection-preference
[/dev/cdc-wdm0] Successfully got system selection preference
	Emergency mode: 'no'
	Mode preference: 'umts, lte, 5gnr'
	Disabled modes: 'none'
	Band preference: 'none'
	LTE band preference: 'none'
	LTE band preference (extended): ''
	NR5G SA band preference: '1, 2, 3, 5, 28, 41, 66, 71, 77, 78, 79'
	NR5G NSA band preference: '1, 2, 3, 5, 28, 41, 66, 71, 77, 78, 79'
	TD-SCDMA band preference: 'none'
	Roaming preference: 'any'
	Network selection preference: 'automatic'
	Service domain preference: 'cs-ps'
	GSM/WCDMA acquisition order preference: 'automatic'
	Usage preference: 'data-centric'
	Voice domain preference: 'ps-preferred'
	Registration restriction: 'unrestricted'
	Acquisition order preference: 'lte, 5gnr, umts'

Can you verify your ACT settting using AT!SELRAT?. In the past it was definitely possible for setting on the AT interpreter side and on the QMI side (which seems to be the “native” interface) to get out of sync. Wouldn’t be surprised if this breaks other parts as well.

With FW 03.06.01.00 and a special operator SIM I get (Bands=0C, SELRAT=0):
+COPS: (1,“Telekom.de”,“Telekom.”,“26201”,12),(0,1,2,3,4),(0,1,2)

Yeah, SELRAT is set to auto:

AT!BAND=0C
OK

AT!BAND?
Index, Name
0C, NR5G ALL
OK

AT!SELRAT?
!SELRAT: 00, Automatic
OK

AT+COPS=?
+CME ERROR: operation not allowed

I wonder if this error just tells me there is no 5G network around, or if it’s really some other type of error.

Hi @aleksander0m , a reminder that you are testing with an early pre-release version of the latest firmware. An official release will be made available in March. There have been some fixes/enhancements made to AT!NRINFO.

at!nrinfo?
!NRINFO:
Connectivity Mode: NSA

NR5G Cell ID: 500
NR5G band: n78 NR5G Carrier ID: 0
NR5G dl bw: 100 MHz NR5G ul bw: 100 MHz
NR5G Tx Power: -10 NR5G Tx chan: 636666
NR5G Rx chan: 636666
NR5G dl MIMO: 0 NR5G ul MIMO: 1
NR5G(sub6) RxM RSSI (dBm): -66.8 NR5G(sub6) RxD RSSI (dBm): -66.1
NR5G(sub6) RxM1 RSSI (dBm): — NR5G(sub6) RxD1 RSSI (dBm): —

NR5G RSRP (dBm): -102 NR5G RSRQ (dB): -11
NR5G SINR (dB): 22.5
OK

Regards, Dave.

@ddixon - @aleksander0m seems to use the latest stable release, 03.04.03.00.

BTW, is there any documentation about !NRINFO output? While most fields are self-explanatory, e.g. the two MIMO fields are strange.

Apparently, the number can’t be 1=active, according to PTS v4 UL only supports SISO in FR1. And I would expect DL MIMO. How is 2x2 and 4x4 MIMO signaled?

This lack of documentation is not only true for !NRINFO, which is a somewhat new command, but also e.g. !LTEINFO, which is several years old and still lacks any meaningful documentation.

Yes, I’m using 03.04.03.00, which according to source.sierrawireless.com is the latest one available. @ddixon this is not a pre-release version, right?

Where could I get 03.06.01.00 for testing? This forum is the closest I have to any sierra support really :slight_smile:

@stefanbruens not sure if it’s too much to ask, but does the same test work with 03.04.03.00? I’m trying to understand whether the 5G-only scan is working only in that new 03.06 release that I don’t yet have, or whether it’s something that also worked in the release I’m playing with (and so it could be some misconfiguration in my side)

@stefanbruens also meant to ask, what happens if you don’t use that “special operator SIM”? i.e. does that same kind of 5G-only scan work with some other SIM card not specifically crafted for 5G SA?

SWIX55C_03.04.03.00 6b63ff jenkins 2021/08/16 19:24:41
At!band? → 00 All Bands
at!selrat? → !SELRAT: 0F, LTE and NR5G only (IIRC same result with 00, All)

+COPS: (1,“Telekom.de”,“TDG”,“26201”,12),(1,“Telekom.de”,“Telekom.”,“26201”,7),(1,“o2 - de”,“o2 - de”,“26203”,7),(1,“vodafone.de”,“Vodafone”,“26202”,7),(0,1,2,3,4),(0,1,2)

Sorry, don’t have any other SIM currently at hand, but IIRC the results with regular Telekom and Vodafone SIM were the same in the past.

I can see the 5GSA network reported there with access tech 12. But does the AT+COPS=? command return correctly if you set it with 5G-only bands? i.e. with AT!BAND=0C