Wrong line endings


#1

M2MStudio is using just LF at the ends of lines; this is incorrect for native windows files - it should be CRLF.

This means, for example, that text files can’t be viewed properly in Notepad.

There’s an option in the Project Properties to change this for new files - but how can I get it changed on existing files?


#2

Easy: open the file in the editor, and File > Convert line delimiters to > make your choice… :wink:


#3

So it is! :blush:

But it does raise another question:

When I go there, the option at the top of the list is ‘Windows [default]’ - so, if Windows is the default, why is it not using Windows line-endings enyhow…? :confused:

The project option for new files is currently ‘Inherited from container’ - so what is the “container” here? And, again, why is it not defaulting to the correct value for the current host system?


#4

I guess that Windows is the default for new files.
M2M Studio is not going to modify all existing files in order to convert them to Windows line endings :exclamation:

By the way, haven’t you a more advanced text editor than Notepad ? :smiley:


#5

It should be the workspace: configured in Preferences > General > Workspace