[WP85] locked in fastboot mode

After updating my FX30 3G with a custom firmware, I lost control over the device. It is locked in bootloader and the device is seen as android device from the PC. I can communicate with it using fastboot but I’m unable to make it boot on Linux again. Swiflash doesn’t detect the device as it is looking for a serial device, but no USB serial device exists at this time.

I tried flashing “kernel” and “rootfs” partitions using fastboot and images found in the “build_bin/tmp/deploy/images/swi-mdm9x15” directory when building a custom firmware using Yocto, but with no luck. Here are the commands I tried:

$ cd build_bin/tmp/deploy/images/swi-mdm9x15
$ fastboot flash kernel ./kernel 
target didn't report max-download-size
sending 'kernel' (3924 KB)...
OKAY [  0.484s]
writing 'kernel'...
OKAY [  0.732s]
finished. total time: 1.217s

$ fastboot flash rootfs ./rootfs
target didn't report max-download-size
sending 'rootfs' (33920 KB)...
OKAY [  4.162s]
writing 'rootfs'...
OKAY [  5.833s]
finished. total time: 9.995s

$ fastboot reboot

finished. total time: 0.052s

After that, the device disconnects from USB, reboot and reconnects again in bootloader.

Any idea on what I am doing wrong or what could be done to make the device boot on linux ?