Wp7702 - Sending sms - cm sms send

#1

Hello,

I am trying to get basic things working out of one of my mangOH red, after successfully having GPS fixing, I have trouble with cellular NW.

I am doing basic SMS send logged through USB ethernet bridge

root@swi-mdm9x28:~# cm sms send 06XXXXXXXX Test
ERROR: Failed to send SMS. Please see log for details

The logs I get:

Jan  6 00:30:06 swi-mdm9x28 user.err Legato: =ERR= | modemDaemon[689]/modemDaemon T=main | le_sms.c le_sms_Send() 3902 | Cannot encode Message Object 0xb25fedf0
Jan  6 00:30:06 swi-mdm9x28 user.err Legato: =ERR= | modemDaemon[689]/modemDaemon T=main | le_sms.c CloseSessionEventHandler() 2311 | SessionRef (0x7f61a7ec) has been closed

It seems surprisingly the device is not able to encode my message. I tried : “Test”, ‘Test’, and various other things without success. The command sendbin with file did not work as well for same log, with however different console return:

root@swi-mdm9x28:~# cm sms sendbin 0663908774 sms.txt
From 'sms.txt'
Sending '0': length[4]
       54 65 73 74 
Error while sending SMS

Does anyone know what I am doing wrong ?
Thank you

#2

i don’t see problem.

root@swi-mdm9x28:~# cm radio
Power: ON
Current Network Operator: CSL
Current RAT: GSM network (LE_MRC_RAT_GSM)
Status: Registered, home network (LE_MRC_REG_HOME)
Signal: Good signal strength (3)
PS: Packet Switched Registered, home network (LE_MRC_REG_HOME)

root@swi-mdm9x28:~#
root@swi-mdm9x28:~# cm sms send 12345678 Test
root@swi-mdm9x28:~#
root@swi-mdm9x28:~# cm info
Device: WP7702
IMEI: 352653090002791
IMEISV: 2
FSN: VU735370340201
Firmware Version: SWI9X06Y_02.16.02.00 bbdb91 jenkins 2018/05/02 11:21:31
Bootloader Version: SWI9X06Y_02.16.02.00 bbdb[ 1063.725787] i2c-msm-v2 78b8000.i2c: NACK: slave not responding, ensure its powered: msgs(n:1 cur:0 tx) bc(rx:0 tx:2) mode:FIFO slv_addr:0x3a MSTR_STS:0x0c1300c8 OPER:0x00000090
91 jenkins 2018/05/02 11:21:31
MCU Version: 002.009
PRI Part Number (PN): 9907365
PRI Revision: 001.001
Carrier PRI Name: GENERIC
Carrier PRI Revision: 001.019_000
SKU: 1103530
Last Reset Cause: Power Down
Resets Count: Expected: 300 Unexpected: 28

#3

Problem solved, this was simply a phone number problem,
I need to use the +33 ahead for the SMS sending.