WP7702 kernel 3.18.44 compilation with gcc 7.3


#1

I’m building the 3.18.44 linux kernel that comes with firmware release 9.1 in a custom yocto build. We’ve just updated our yocto layers to run the sumo release (we used pyro before). Now, when we build the kernel, it hangs during boot, freezes for a few seconds and then resets.

Most of the time this happens relatively early in the boot process, after about 5 secs, but sometimes I get all the way to a login shell before it freezes. The kernel sources and config is exactly the same in both builds, just that the build system has been updated.

I don’t get any printouts about panic or anything, it just freezes and resets. I tried comparing the logs from a working kernel and one that freezes, and they are almost identical and gives no clues of what might be wrong.

Has anyone else seen this or something similar?


#2

Some additional info: When we compile with gcc 5.4 it works fine. However both gcc 6.4 (also available in pyro) and gcc 7.3 (the only one available in sumo) causes the kernel to freeze, usually after this printout (but not always):

clock_late_init: Removing enables held for handed-off clocks

#3

I managed to rebase the kernel against 3.18.125 (it took a while) but still the same freeze. I guess we’ll just have to wait for the next release of the very old kernel from Sierra :frowning: