WP76xx How to Disable UBIFS in R17 Yocto Build

Hi, I am trying to upgrade the WP76xx Kernel to Latest R17 Release from Sierra Wireless from R16_01. Referring to this Flash size wp7607 - Legato Forum, I had a similar issue and solved rootfs file size issue by disabling UBIFS by making the following changes (See the Pic)

Now I am trying the same changes in the R17 Release, however, after this change, I am facing the yocto build error. (See pic)

Why do you need to remove ubifs?

As I said, rootfs sizes need to be reduced. If we use ubifs the size will be more.

MicrosoftTeams-image (6)

mtd13 partition has size limit.

According to release note, this system partition size is fixed

Do you mean you need extra space to store data?

Actually, we are adding some files to rootfs. It appears that rootfs should not be more than 30MB. If we use ubifs resulting rootfs in ubifs format will occupy more space so we cannot include our files into it.

We have already did using the patch file (details are in the sceenshot shared). Here in r16 it works fine.

does it work if you do “make” after “make clean” in order to have a clean build?

how about just modifying mdm9x28-image.inc but not modifying swi-mdm9x28.conf?
If i just modify mdm9x28-image.inc, the compilation is working on my side.

I tried this, it works without error for a generic image (i.e. without any of our files in rootfs). After adding our files I get the same error.

You mean you just modify mdm9x28-image.inc?

Btw, how do you add files?

Files are adding using the recipes and .bb file

do_install() {
install -m 0755 -d ${D}${sysconfdir}/new_folder
install -m 0644 ${WORKDIR}/your_file ${D}${sysconfdir}/new_folder/your_file

Then how about just adding a simple helloworld recipe?

I just tested with this simple recipe in R17:
jacktest.7z (1.0 KB)

I can compile with “for rootfs_type in squashfs; do” in mdm9x28-image.inc

Can you try adding a 10MB file ?

maybe it is too large for that partition…
why don’t you start with a smaller one and see if it works?

What is the size limit for that partition?

According to your screenshot, it is 30MB
properly you need to make some trial with some smaller files

Another option is to put your file in /home/root which is userapp partition

1 Like

I tried reducing my file size to 5MB and it worked without any ubifs-related patch.