WP76XX /dev/ttyHS0 issues

I am using WP76XX for our project and the settings are as below
root@swi-mdm9x28-wp:~# echo -e “AT!MAPUART?\r” | microcom -t 2000 /dev/ttyAT
!MAPUART: 17,17

One energy meter is connected to this Port and communication over RS232.

One issue , I noticed is after close(tty) system call , see some data/special characters(junk) still on TX line in RS232 Probing.
Would like to know how to check Close() system call has really closed the port or is there any delay in Sierra to close the port. Basically how to debug

can it be some noise signal?

  1. Open () of port and close() of the port → will see special characters / junk on TX line for 30 - 35sec
  2. After close , when I tried cat /dev/ttyHS0 , I could see that junk characters will just stop for a short time and again will continue. Tested multiple times and noticed same behaviour.
    When the port is left open, there is no issue.
    So would like to know or debug if any close(tty) is really cleaning up the device.

you can try to disable the auto suspend mode and see if there is improvement

Thanks for the reply.
Details are below :slight_smile: root@swi-mdm9x28-wp:~# cm info
Device: WP7608-1
IMEI: 352914090196482
FSN: 3P022685380610
Firmware Version: SWI9X07Y_02.37.03.00 73df45 jenkins 2020/04/08 10:59:14
Bootloader Version: SWI9X07Y_02.37.03.00 73df45 jenkins 2020/04/08 10:59:14
MCU Version: 002.015
PRI Part Number (PN): 9908672
PRI Revision: 001.002
Carrier PRI Name: GENERIC
Carrier PRI Revision: 002.095_000
SKU: 1104201
Last Reset Cause: Reset, User Requested
Resets Count: Expected: 293 Unexpected: 0
I tried to disable the
cat /sys/devices/platform/msm_serial_hs.0/tty/ttyHS0/device/power/autosuspend_delay_ms
to -1 but no change .

can you try FW R13 and see if there is problem?