WISMO218, READY pin goes low after 14 seconds


#1

Hello,

We experiencing a very strange behavior with a WISMO218 modem. It is controlled by an external uC. After powering up the modem and toggling the ON/OFF pin, the READY pin goes high. Exactly as described in the datsheet.

The problem is that 14 seconds after (give or take 1 second), the ready pin goes low irrespective of the uC sending AT commands or not.

We have isolated the problem to the SIM card. Without the card inserted, the modem READY pin remains high indefinitely although we are limited on the commands which the uC can send.

With the SIM card, the modem seems to power off automatically 14 seconds after the READY pin had gone high.

We also tried to get the phonebook directory, as well as making a call. In both cases, the modem replies with CMEE error value 100 (meaning “unknown”).

Did anybody experienced this before ? Any advice on what we can be doing wrong ? We know it is not the SIM card because we tried with cards, and the result is always the same.

Thanks,

Nelson Gon\c calves


#2

An update on our setup:

We are looking at the SIM card communication lines and the modem and the card are in fact talking (a lot it seems), although I don’t know the protocol which is being used.

So I guess that the SIM card electric connections are working. However the mode still powers of 14 seconds after the ready pin went high.

We tried to reset the modem with “AT+CFUN=1,1”, the modem reseted, the SIM card was also reseted and the communications proceeded as before. But 14 seconds after the READY pin was high for the first time (that is after power up, not after the reset by the AT command), the modem again powers off.

We have it connected to a lab power supply and we allow for 1.5A of current, but so far it only seems to draw aroud 30 mA (peek value was 70 mA).

Any sugestions ?


#3

Update:

We are now convinced that the modem has an internal watchdog (most likely by hardware) which for some reason is switching off the modem.

We have double checked the power supply, the electric components, measured all of the signals available to us and changed the sequence of AT commands (from no command to strange commands). In all cases, the modem switched of 13~14 seconds after it was power up.

This is strange. We had used this modem before and never experienced this type of problems. Is there anybody from Sierra that reads the forum, who can supply some answers ?

Thanks,

Nelson Gon\c calves


#4

Hi,

Does issue happen only when particular SIM inserted? Do you have other WISMO218 facing same issue?
Can you try to enable AT+PSSREP=1 and send AT+CPIN?;+CREG? during 14 sec and share the AT cmd log?

Also, which FW version is running?

Thx.
L


#5

Hello,

It appears that it was the SIM card. We changed it and everything began working. I did not try with the commands you suggested because it is working now and I would need to make significant changes to the firmware that is controlling the hardware.

Also, I apologize for the late reply but after a couple of days, I went on vacations and I only returned now.

Thanks,

Nelson