WIPsoft 5.54 problem with MMS client


#1

Hello guys,

We are using WIPSoft (Internet Application) plug-in ver. 5.54 with AirPrime SL6987 FW ver. 7.51.0; we have tested all embedded protocols, everything is working just fine with UDP, TCP, FTP, SMTP, POP3 and HTTP, but we do not arrive to send MMS following the example from WIPsoft User Guide (we are just trying to send one JPEG image as MMS):

AT+WOPEN=1
OK

AT+WIPCFG=1
OK

AT+WIPBR=1,6
OK

AT+WIPBR=2,6,11,“mms”
OK

AT+WIPBR=2,6,0,""
OK

AT+WIPBR=2,6,1,""
OK

AT+WIPBR=4,6,0
OK

AT+WIPBR=3,6,15
+WIND: 15,3,"+08",4,“12/10/08,12:17:39+08”,6,“1”
+WIPBR: 6,15,“172.30.146.175”
OK

AT+WIPBR=3,6,25
+WIPBR: 6,25,“255.255.0.0”
OK

AT+WIPBR=3,6,17
+WIPBR: 6,17,“217.65.192.101”
OK

AT+WIPBR=3,6,18
+WIPBR: 6,18,“217.65.192.102”
OK

AT+WIPCREATE=8,1,“217.65.192.33”,8080,“http://mms.telenor.rs/servlets/mms
OK
+WIPREADY: 8, 1

AT+WIPOPT=8,1,2,81,“0637380797”
OK

AT+WIPOPT=8,1,2,91,“0638032238”
OK

AT+WIPOPT=8,1,2,90,0
OK

AT+WIPOPT=8,1,2,89,1
OK

AT+WIPOPT=8,1,2,92,0
OK

AT+WIPOPT=8,1,2,93,4,54686,"/tmp/test.jpeg",""
OK

AT+WIPFILE=8,1,2,"/tmp/test.jpeg",""
CONNECT
OK

+WIPFILE: 8,1,54686

AT+WIPOPT=8,1,2,96
+CME ERROR: 860

We have tried to use also Multipart Related format, specifying SMIL presentation file, but the result is always the same, error 860 (protocol undefined or internal error).

Did anybody arrive to send MMS using AT+WIP commands, if yes please share with us your working example?


#2

Hi,

Did you try with some other wipsoft version(lower versions 5.42,5.43 etc with firmware versions 7.46,7.47 etc))?
Are the results same?

Thanks.


#3

YES, result is always the same. We have tried SL6987 WIPsoft 5.41.0, 5.43.0, 5.43.1 and the latest 5.54.


#4

OK, we have resolved the Mystery, the key point was that when we enabled debug log (AT+WIPCFG=2,5,1), we saw that MMS option WIP_MMS_SUBJECT is mandatory!!! It is not written like this in WIPsoft Manual, nor in examples. So we added:

AT+WIPOPT=8,1,2,87,“MMS Message Subject”
OK

and it works :smiley:

BUT, the problem is also that MMS code inside WIPsoft is not on the same level as code in modern mobile phones, it works with some MMSC but with all. We found SIM that is working perfectly inside mobile phone to send MMS, but it is not working with SL6087 and WIPsoft with exactly the same parameters!


#5

Had the same error and had read this post and added a subject but still got the same error.
Found in wip_mms.h - line 206

  • @note Options WIP_COPT_MMS_FROM and WIP_COPT_MMS_SUBJECT are mandatory.
  •     \n\n The option WIP_COPT_MMS_MESSAGE_CLASS only supports
    
  •     WIP_MMS_MESSAGE_PERSONAL for many operators.
    
  •     \n\n The option WIP_COPT_MMS_PRIORITY doesn’t support WIP_MMS_PRIORITY_HIGH.
    

The From number is manditory.
Added AT+WIPOPT=8,1,2,91,“0432112345” and WIP now sends the MMS

Hope this helps
Noel