Win 10 MC7430 com ports setting usbcomp

Hi All,

We are using MC7430s with Win 10 and it looks to be setting the devices to MBIM mode where only the network adapter is showing under device manager.

How can I set the usbcomp to be as below through windows without being able to run the at command?

I’ve tried setting it in the config.ini with the driver installer and using driversint.exe with the usbcomp argument, I can see it in the driversinstall log however no modems or com port are show in device manager.

  1. are the settings I tried correct?
  2. are there any win10 settings, utilities or registry keys I can change?
  3. can I use .net and the gobiapi?
  4. I saw reference to “Sierra Wireless Set USB Composition Application” in the forums is this something that would work for the MC7430 and where could I get it?

thanks
Ryan

at!usbcomp?
Config Index: 1
Config Type: 1 (Generic)
Interface bitmask: 0000100D (diag,nmea,modem,mbim)

tried
config.ini
[Default Values]
CHECKFORDEVICE=0
LOCATIONDRIVER=1
WIN8LOCATION=1
USBCOMP=0000100D

DriverInst.exe -USBCOMP=0000100D -rw
DriverInst.exe -usbcomp=4109 -rw

Hi @ryan.perry

You can use ModemManager tool on Linux host to set USB Composition
Please try qmicli --dms-swi-set-usb-composition=8

qmicli --dms-swi-get-usb-composition will list the USB Composition = 8
qmicli --device-open-mbim -p -d /dev/cdc-wdm0 --dms-swi-get-usb-composition
[/dev/cdc-wdm0] Successfully retrieved USB compositions:
USB composition 6: DM, NMEA, AT, QMI
USB composition 8: DM, NMEA, AT, MBIM
USB composition 9: MBIM

Please help to mark “Solution” if your question is answered.

Thanks Donald,

Is there a win10 equivalent of ModemManager?

Hi @ryan.perry

You can try with these steps for win 10:

  1. Uninstalled all Sierra Wireless drivers.
  2. Installed GenericDriverSetup_Build4836.exe
  3. Make sure modem was disconnected.
  4. In the Driver Packages directory run “DriverInst.exe USBCOMP=8” from an Administrator prompt.
  5. The default Generic Broadband driver is installed.
  6. Update the driver of the network adapter. Choose Driver => Have Disk => c:\Program Files(x86)\Sierra Wireless\driver package\driver\swg3kmdm00.inf
  7. “Sierra Wireless Incorporated” => “Sierra Wireless Mobile Broadband Network Adapter”

Thanks Donald

USBComp=8 for the win

modem and nmea ports are now showing.