What is the right procedure to activate any specific PDP context ID?

What is the right procedure to activate any specific PDP context ID?

I have tried to activate 3rd context with AT!SCACT=1,3 but it always activates first context.

AT+CGDCONT?
+CGDCONT: 1,“IP”,"",“0.0.0.0”,0,0,0,0
+CGDCONT: 2,“IP”,"",“0.0.0.0”,0,0,0,0
+CGDCONT: 3,“IP”,"",“0.0.0.0”,0,0,0,0
+CGDCONT: 4,“IPV4V6”,“vzwapp”,“0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0”,0,0,0,0
+CGDCONT: 5,“IPV4V6”,“vzw800”,“0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0”,0,0,0,0
+CGDCONT: 6,“IPV4V6”,“vzwclass6”,“0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0”,0,0,0,0

OK
AT+CGCONTRDP
+CGCONTRDP: 1,5,vzwadmin,10.130.198.34,198.224.171.135,198.224.169.135

OK
at!scact?
!SCACT: 1,0
!SCACT: 2,0
!SCACT: 3,1
!SCACT: 4,0
!SCACT: 5,0
!SCACT: 6,0

OK

AT+CGATT=1 is always activating first context. How do I stop auto selection of first context?

subsequent AT+CGACT=1,3, does not have any effect except it activates 2 contexts.

tried AT+CGATT=0, then AT+CGACT=1,3
It shows
AT+CGACT=1,3
+CME ERROR: no network service

AT!GSTATUS?
!GSTATUS:
Current Time: 559 Temperature: 36
Reset Counter: 3 Mode: ONLINE
System mode: Unknown PS state: Not attached

OK

Hi akn,
You can not activate 2 PDP contexts with the same APN,
Please configure different APN for CID 1 and CID 3.

Thanks,

Do I need to run AT+CGACT=1,3 to select context ID 3 or it will automatically get selected.

I am unable to activate any context with the use of AT+CGACT.

What is the right procedure to activate any specific context ID ?

Hi akn,
If you use correct firmware for Verizon, the CID 3 will register automatically.
If not, you can use AT+CGACT=1,3

Thanks,

I always receive error with “AT+CGACT=1,3”

Currently It is showing
AT+CGACT=1,3
+CME ERROR: no network service

AT+CGATT=1
+CME ERROR: no network service

AT+CGDCONT?
+CGDCONT: 1,“IP”,“vzims”,“0.0.0.0”,0,0,0,0
+CGDCONT: 2,“IP”,“vzadmin”,“0.0.0.0”,0,0,0,0
+CGDCONT: 3,“IPV4V6”,"",“0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0”,0,0,0,0
+CGDCONT: 4,“IPV4V6”,“vzwapp”,“0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0”,0,0,0,0
+CGDCONT: 5,“IPV4V6”,“vzw800”,“0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0”,0,0,0,0
+CGDCONT: 6,“IPV4V6”,“vzwclass6”,“0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0”,0,0,0,0

It starts happening after AT+CGDCONT=3,“IPV4V6”,""

I am trying to setup Class-3 connection with empty APN for Verizon. What are the AT commands to setup a data connection in this case?

Please reload newest firmware for Verizon. By default, Verizon firmware will use PDP 3 for internet connection.

Thanks,

1 Like